C语言Matrix编程题——[Arrays]D. Liang 6.5 Printing distinct numbers

[Arrays]D. Liang 6.5 Printing distinct numbers

Description:

Write a program that reads in n integers and displays distinct numbers (ie., if a number appears multiple times, it is displayed only once).

Input:

The first line is a positive integer t for the number of test cases.
Each test case contains two lines. The first line is an integer n (0<n<=100). The second line contains n integers.

Output:

For each test case, outputs the distinct numbers in order in which they were read, seperated by one blank.

Sample Input:

2
3
1 2 1
4
2 1 2 1

Sample Output:

1 2
2 1

Programme:

//Date:2020/4/26
//Author:Kamenrider Justice
#include<stdio.h>
int main()
{
   int n,i,j,k,num;//n是运行的次数,num是输入的个数
   scanf("%d",&n);
   int number[100];//储存输入的数
   int flag;   //判断是否有重复的数 
   for(i=0;i<n;i++)
   {      
      scanf("%d",&num);
      for(j=0;j<num;j++)//储存数到数组
      {
         scanf("%d ",&number[j]);
      }
      printf("%d",number[0]);
      for(j=1;j<num;j++)
      {
         flag=1;//使flag回到初始状态
         for(k=0;k<j;k++)
         {    
            if(number[j]==number[k])
            {
               flag=0;
            }
         }
         if(flag)//如果没有重复的就输出,可保证顺序和输入时一致
         {
            printf(" %d",number[j]);
         }
      }
      printf("\n");
   }
   return 0;
}

PyTorch从入门到实战一次学会

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值