[Arrays]D. Liang 6.5 Printing distinct numbers.c

Description

Write a program that reads in n integers and displays distinct numbers (ie., if a number appears multiple times, it is displayed only once).

Input

The first line is a positive integer t for the number of test cases.
Each test case contains two lines. The first line is an integer n (0<n<=100). The second line contains n integers.

Output

For each test case, outputs the distinct numbers in order in which they were read, seperated by one blank.

Sample Input

2
3
1 2 1
4
2 1 2 1

Sample Output

1 2
2 1
//   Date:2020/4/18
//   Author:xiezhg5 
#include <stdio.h>
int main(void)
{
    int m;
    scanf("%d",&m);
    int a[20][100];          //巧妙定义一个二维数组 
    int i,j,num[100];
    for(i=0;i<m;i++)
    {
        scanf("%d",&num[i]);   //把输入的数放在一个新数组中 
        for(j=0;j<num[i];j++)
        scanf("%d",&a[i][j]);
    }
    int k;
    for(i=0;i<m;i++)
    {
        printf("%d",a[i][0]);    //输出第一列的数组元素 
        for(j=1;j<num[i];j++)   
        {
            for(k=0;k<j;k++)
            {
                if(a[i][k]==a[i][j]) //元素相同则立即跳出循环 
                break;
            }
            if(k==j)              //如果不同就输出注意次序 
            printf(" %d",a[i][j]);
        }
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值