BFS入门例题

http://acm.hdu.edu.cn/showproblem.php?pid=2717

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 28320 Accepted Submission(s): 7768

Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17

Sample Output
4

Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
仅供大家参考
1.每种结点有三种情况,+1,-1,*2分别搜索即可,特殊情况如果已经超了只能倒退往回一步步走
AC代码

#include<bits/stdc++.h>
using namespace std;
int s,d;
int vis[100001];
struct node{
	int x;
	int step;
};
void bfs(){
	queue<node> q;
	node a,next,p;
	a.x=s;a.step=0;vis[s]=1;
	q.push(a);
	while(!q.empty()){
		p=q.front();
		q.pop();
		if(p.x==d){
			printf("%d\n",p.step);
			break;
		}
		for(int i=0;i<2;i++){
			//0传送,1行走
			if(i==0){
				int xx=p.x*2;
				if(xx>=0&&xx<=100000&&!vis[xx]){
					next.x=xx;
					next.step=p.step+1;
					vis[xx]=1;
					q.push(next);
				} 
			}
			if(i==1){
				int x1=p.x+1;
				int x2=p.x-1;
				if(x1>=0&&x1<=100000&&!vis[x1]){
					next.x=x1;
					next.step=p.step+1;
					vis[x1]=1;
					q.push(next);
				}
				if(x2>=0&&x2<=100000&&!vis[x2]){
					next.x=x2;
					next.step=p.step+1;
					vis[x2]=1;
					q.push(next);
				}
			}
		}
	}
}
int main()
{
	while(scanf("%d%d",&s,&d)!=EOF){
		memset(vis,0,sizeof(vis));
		if(s>d) printf("%d\n",s-d);
	    else bfs();
	}	
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值