HDU - 3792- Twin Prime Conjecture【 数论 】 题解

1.题目

If we define dn as: dn = pn+1-pn, where pi is the i-th prime. It is easy to see that d1 = 1 and dn=even for n>1. Twin Prime Conjecture states that “There are infinite consecutive primes differing by 2”.
Now given any positive integer N (< 10^5), you are supposed to count the number of twin primes which are no greater than N.
Input
Your program must read test cases from standard input.
The input file consists of several test cases. Each case occupies a line which contains one integer N. The input is finished by a negative N.
Output
For each test case, your program must output to standard output. Print in one line the number of twin primes which are no greater than N.
Sample Input
1
5
20
-2
Sample Output
0
1
4

2.代码

#include<iostream>
#include<cstdio>
using namespace std;
const int maxn=1e6+10;
int a[maxn],prime[maxn];
void isPrime()
{
  prime[1]=1;
  prime[0]=1;
  for(int i=2;i<maxn;i++)
  {
     if(prime[i]==0)
	 {
	 	 for(int j=i+i;j<maxn;j+=i)
	 	  prime[j]=1;
	 }	
  }	
} 
int main()
{   
    isPrime();
    a[5]=1;///初值 
    for(int i=1;i<maxn;i++)
    {
    	a[i+2]=a[i+1];  ///递推式 
    	if(prime[i]==0&&prime[i+2]==0)
    	  a[i+2]=a[i+1]+1;
	}
	int n;
	while(cin>>n)
	{
		if(n<0)  break;
		cout<<a[n]<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林小鹿@

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值