HDU - 6322 - Problem D. Euler Function 【欧拉函数 + 规律】题解

1.题目

In number theory, Euler’s totient function φ(n) counts the positive integers up to a given integer n that are relatively prime to n. It can be defined more formally as the number of integers k in the range 1≤k≤n for which the greatest common divisor gcd is equal to 1.
For example, \varphi(9) = 6 because 1, 2, 4, 5, 7 and 8 are coprime with 9. As another example, \varphi(1) = 1 since for n = 1 the only integer in the range from 1 to n is 1 itself, and \gcd(1, 1) = 1.
A composite number is a positive integer that can be formed by multiplying together two smaller positive integers. Equivalently, it is a positive integer that has at least one divisor other than 1 and itself. So obviously 1 and all prime numbers are not composite number.
In this problem, given integer k, your task is to find the k-th smallest positive integer n, that \varphi(n) is a composite number.
Input
The first line of the input contains an integer T(1\leq T\leq100000), denoting the number of test cases.
In each test case, there is only one integer k(1\leq k\leq 10^9).
Output
For each test case, print a single line containing an integer, denoting the answer.
Sample Input
2
1
2
Sample Output
5
7

2.代码

#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
   int t;
   cin>>t;
   while(t--)
   {
           int k;
   	   cin>>k;
       if(k==1)
	     cout<<'5'<<endl;
	   else if(k==2)
	     cout<<'7'<<endl;
	   else
	     cout<<k+5<<endl;	
   }
   return 0;	
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林小鹿@

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值