Euler Function(欧拉方程)(找规律)

                                           Euler Function

                   Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
                                                Total Submission(s): 291    Accepted Submission(s): 257

Problem Description

In number theory, Euler's totient function φ(n) counts the positive integers up to a given integer n that are relatively prime to n. It can be defined more formally as the number of integers k in the range 1≤k≤n for which the greatest common divisor gcd(n,k) is equal to 1.
For example, φ(9)=6 because 1,2,4,5,7 and 8 are coprime with 9. As another example, φ(1)=1 since for n=1 the only integer in the range from 1 to n is 1itself, and gcd(1,1)=1.
A composite number is a positive integer that can be formed by multiplying together two smaller positive integers. Equivalently, it is a positive integer that has at least one divisor other than 1 and itself. So obviously 1 and all prime numbers are not composite number.
In this problem, given integer k, your task is to find the k-th smallest positive integer n, that φ(n) is a composite number.

Input

The first line of the input contains an integer T(1≤T≤100000), denoting the number of test cases.
In each test case, there is only one integer k(1≤k≤10^9).

Output

For each test case, print a single line containing an integer, denoting the answer.

Sample Input

2 1 2

Sample Output

5 7

Source

2018 Multi-University Training Contest 3

 

 

以欧拉方程为背景,欧拉方程如下:

题意:让你输出第n个φ(h)为合数的h。

因为k的范围太大,到了1e9,只能尝试找规律。找规律的代码如下(素数筛+欧拉方程)

#include<bits/stdc++.h>
#define ll long long
using namespace std;

int a[40000],vis[40000],pri[40000];int cnt=0;

void getpri()
{
    memset(vis,0,sizeof(vis));

    for(int i=2;i<=40000;i++)
    {
        if(!vis[i])
        {
            pri[cnt++]=i;
            for(long long j=i*i;j<40000;j+=i)
                vis[j]=1;
        }
    }
}

int euler(int n)
{
    int ans=n,j=0;
    //int pri[1000];
    while(n!=1)
    {
        if(n%pri[j]==0)
        {
            ans/=pri[j];
            ans*=pri[j]-1;
            while(n%pri[j]==0)  n/=pri[j];
        }
        j++;
    }
    return ans;
}

int main()
{
    int a;
    getpri();
    for(int i=1;i<200;i++)
        printf("%d\n",vis[euler(i)]);


    return 0;
}



发现除了前几个特例之外,后面的数的欧拉方程全是合数。

最终代码:

#include<bits/stdc++.h>
#define ll long long
using namespace std;

int a[40000],vis[40000],pri[40000];int cnt=0;

int main()
{
    int a,t;
    scanf("%d",&a);
    while(a--)
    {
        scanf("%d",&t);
        printf("%d\n",t+4+(t>1));
    }

    return 0;
}



 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值