Prime Distance

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.
Your program is given 2 numbers: L and U ( 1 < = L < U < = 2 , 147 , 483 , 647 1<=L< U<=2,147,483,647 1<=L<U<=2,147,483,647), and you are to find the two adjacent primes C 1 C_1 C1 and C 2 C_2 C2 ( L < = C 1 < C 2 < = U L<=C_1< C_2<=U L<=C1<C2<=U) that are closest (i.e. C 2 − C 1 C_2-C_1 C2C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D 1 D_1 D1 and D 2 D_2 D2 ( L < = D 1 < D 2 < = U ) (L<=D_1< D_2<=U) (L<=D1<D2<=U)where D 1 D_1 D1 and D 2 D_2 D2 are as distant from each other as possible (again choosing the first pair if there is a tie).
Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.
Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

题目含义:给定两个整数 ,求闭区间 中相邻两个质数差值最小的数对与差值最大的数对。当存在多个时,输出靠前的素数对。

历程:比赛的时候有两个学长做出来了,心里想着自己应该也可以,但是。。我居然在想如何将1 - 231的中所有的素数打表然后装进数组中,然后发现好像有点多的样子。。最后也没能做出来。

思路:题目中要求在给定的区间上找出所有的素数,我们考虑普通的筛素数法是怎样将素数筛掉的,首先我们要先证明一点,就是合数肯定是被他最小的质因子筛掉的,这一点很容易理解,那么我们只要预先求出1 - 231之间所有合数的最小质因子就可以筛掉所有的1 - 231之间
所有的合数。
注意:这个题目的范围在int 的边缘,所以要注意数据溢出的情况。

代码:看着有点长,其实主要思路的代码就是一点,用的是线性筛素数和普通筛素数的结合版。


#include <cstdio>
#include <algorithm>
#include <iostream>
#include <cstring>

using namespace std;

typedef long long LL;

const int N = 1000100, INF = 0x3f3f3f3f;

int prime[N], idx, l, r;
bool vis[N], ans[N];

void get()
{
	int t = 46342;
	for (int i = 2; i <= t; i++)
	{
		if (!vis[i])
		{
			prime[idx++] = i;

		}
		
		for (int j = 0; prime[j] <= t / i; j++)
		{
			vis[prime[j] * i] = true;
			if (i % prime[j] == 0) break;
		}
	}
}

void get_prime()
{
	for (int i = 0; i < idx; i++)
	{
		for (int j = max(((LL)l + prime[i] - 1) / prime[i], 2LL); j <= r / prime[i]; j++)
		{
			ans[prime[i] * j - l] = true;

			
		}
	}
}


int main()
{
	get();
	while (cin >> l >> r)
	{
		memset(ans, 0, sizeof ans);
		get_prime();
		if (l == 1) ans[0] = true;

		int max_l, max_r, min_l, min_r, max_v = 0, min_v = INF, i = 0, ed = 0;

		for (i = 0; i <= r - l; i++)
			if (ans[i] == false)
			{
				ed = i++;
				break;
			}
		for (; i <= r - l; i++)
		{
			if (ans[i] == false)
			{
				if (max_v < i - ed) max_l = ed, max_r = i, max_v = i - ed;
				if (min_v > i - ed) min_l = ed, min_r = i, min_v = i - ed;
				ed = i;
			}
		}
		if (min_v == INF) cout << "There are no adjacent primes.\n";

		else
		{
			printf("%d,%d are closest, %d,%d are most distant.\n", min_l + l, min_r + l, max_l + l, max_r + l);
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值