2115: [Wc2011] Xor
Input
第一行包含两个整数N和 M, 表示该无向图中点的数目与边的数目。 接下来M 行描述 M 条边,每行三个整数Si,Ti ,Di,表示 Si 与Ti之间存在 一条权值为 Di的无向边。 图中可能有重边或自环。
Output
仅包含一个整数,表示最大的XOR和(十进制结果),注意输出后加换行回车。
Sample Input
5 7
1 2 2
1 3 2
2 4 1
2 5 1
4 5 3
5 3 4
4 3 2
Sample Output
6
HINT
思路:先将每一个环给求出来然后储起来,再将1到n的边的XOR的值依次贪心去异或这些环的线性基。
#include <bits/stdc++.h>
#define MAX_INT ((unsigned)(-1)>>1)
#define MIN_INT (~MAX_INT)
#define db printf("where!\n");
using namespace std;
typedef unsigned long long ll;
const int maxn=5e5+5;
int read()
{
int c=0;int flag=1;
char s;
while((s=getchar())>'9'||s<'0')if(s=='-')flag=-1;
c=s-'0';
while((s=getchar())<='9'&&s>='0') c=c*10+s-'0';
return c*flag;
}
const int maxbit=64;
struct edge
{
int to;
ll val;
};
vector<edge>G[maxn];
ll xorsum[maxn];
ll A[maxn];
ll P[maxbit];
int sz;
bool v[maxn];
void dfs(int nowp,ll x)//求环
{
v[nowp]=1;
xorsum[nowp]=x;//1到nowp这个点的异或值
int len=G[nowp].size();
for(int i=0;i<len;i++){//遍历nowp的下一个点
int to=G[nowp][i].to;//下一个点
if(v[to]){//有环
if(xorsum[nowp]^G[nowp][i].val^xorsum[to])//如果不是0环
A[++sz]=xorsum[nowp]^G[nowp][i].val^xorsum[to];//存起来
}
else{
dfs(to,xorsum[nowp]^G[nowp][i].val);//继续深搜
}
}
}
int main(void)
{
int n,m;cin>>n>>m;
int from,to;
ll weight;
for(int i=1;i<=m;i++){
cin>>from>>to>>weight;
G[from].push_back({to,weight});
G[to].push_back({from,weight});
}
dfs(1,0);
//求线性基
for(int i=1;i<=sz;i++){
for(int j=maxbit-1;j>=0;j--){
if((A[i]>>j)&1){
if(P[j]){
A[i]^=P[j];
}
else{
P[j]=A[i];
break;
}
}
}
}
ll ans=xorsum[n];//ans等于1到n的点的异或值
for(int i=maxbit-1;i>=0;i--){
ans=max(ans,ans^P[i]);//从大到小把需要的线性基个异或进去
}
cout<<ans<<endl;
return 0;
}