6-12 二叉搜索树的操作集 (30 分)

本题要求实现给定二叉搜索树的5种常用操作。

函数接口定义:

BinTree Insert( BinTree BST, ElementType X );
BinTree Delete( BinTree BST, ElementType X );
Position Find( BinTree BST, ElementType X );
Position FindMin( BinTree BST );
Position FindMax( BinTree BST );

函数Insert将X插入二叉搜索树BST并返回结果树的根结点指针;
函数Delete将X从二叉搜索树BST中删除,并返回结果树的根结点指针;如果X不在树中,则打印一行Not Found并返回原树的根结点指针;
函数Find在二叉搜索树BST中找到X,返回该结点的指针;如果找不到则返回空指针;
函数FindMin返回二叉搜索树BST中最小元结点的指针;
函数FindMax返回二叉搜索树BST中最大元结点的指针。
裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

typedef int ElementType;
typedef struct TNode *Position;
typedef Position BinTree;
struct TNode{
    ElementType Data;
    BinTree Left;
    BinTree Right;
};

void PreorderTraversal( BinTree BT ); /* 先序遍历,由裁判实现,细节不表 */
void InorderTraversal( BinTree BT );  /* 中序遍历,由裁判实现,细节不表 */

BinTree Insert( BinTree BST, ElementType X );
BinTree Delete( BinTree BST, ElementType X );
Position Find( BinTree BST, ElementType X );
Position FindMin( BinTree BST );
Position FindMax( BinTree BST );

int main()
{
    BinTree BST, MinP, MaxP, Tmp;
    ElementType X;
    int N, i;

    BST = NULL;
    scanf("%d", &N);
    for ( i=0; i<N; i++ ) {
        scanf("%d", &X);
        BST = Insert(BST, X);
    }
    printf("Preorder:"); PreorderTraversal(BST); printf("\n");
    MinP = FindMin(BST);
    MaxP = FindMax(BST);
    scanf("%d", &N);
    for( i=0; i<N; i++ ) {
        scanf("%d", &X);
        Tmp = Find(BST, X);
        if (Tmp == NULL) printf("%d is not found\n", X);
        else {
            printf("%d is found\n", Tmp->Data);
            if (Tmp==MinP) printf("%d is the smallest key\n", Tmp->Data);
            if (Tmp==MaxP) printf("%d is the largest key\n", Tmp->Data);
        }
    }
    scanf("%d", &N);
    for( i=0; i<N; i++ ) {
        scanf("%d", &X);
        BST = Delete(BST, X);
    }
    printf("Inorder:"); InorderTraversal(BST); printf("\n");

    return 0;
}
/* 你的代码将被嵌在这里 */

输入样例:
10
5 8 6 2 4 1 0 10 9 7
5
6 3 10 0 5
5
5 7 0 10 3
输出样例:
Preorder: 5 2 1 0 4 8 6 7 10 9
6 is found
3 is not found
10 is found
10 is the largest key
0 is found
0 is the smallest key
5 is found
Not Found
Inorder: 1 2 4 6 8 9

代码如下

#include <stdio.h>
#include <stdlib.h>

typedef int ElementType;
typedef struct TNode *Position;
typedef Position BinTree;
struct TNode{
    ElementType Data;
    BinTree Left;
    BinTree Right;
};

void PreorderTraversal( BinTree BT ); /* 先序遍历,由裁判实现,细节不表 */
void InorderTraversal( BinTree BT );  /* 中序遍历,由裁判实现,细节不表 */

BinTree Insert( BinTree BST, ElementType X );
BinTree Delete( BinTree BST, ElementType X );
Position Find( BinTree BST, ElementType X );
Position FindMin( BinTree BST );
Position FindMax( BinTree BST );

int main()
{
    BinTree BST, MinP, MaxP, Tmp;
    ElementType X;
    int N, i;

    BST = NULL;
    scanf("%d", &N);
    for ( i=0; i<N; i++ ) {
        scanf("%d", &X);
        BST = Insert(BST, X);
    }
    printf("Preorder:"); PreorderTraversal(BST); printf("\n");
    MinP = FindMin(BST);
    MaxP = FindMax(BST);
    scanf("%d", &N);
    for( i=0; i<N; i++ ) {
        scanf("%d", &X);
        Tmp = Find(BST, X);
        
        if (Tmp == NULL) printf("%d is not found\n", X);
        else {
            printf("%d is found\n", Tmp->Data);
            if (Tmp==MinP) printf("%d is the smallest key\n", Tmp->Data);
            if (Tmp==MaxP) printf("%d is the largest key\n", Tmp->Data);
        }
    }
    scanf("%d", &N);
    for( i=0; i<N; i++ ) {
        scanf("%d", &X);
        BST = Delete(BST, X);
    }
    printf("Inorder:"); InorderTraversal(BST); printf("\n");

    return 0;
}
void PreorderTraversal( BinTree BT ){
	if(BT){
		printf(" %d", BT->Data);
		PreorderTraversal(BT->Left);
		PreorderTraversal(BT->Right);
	}
}
void InorderTraversal( BinTree BT ){
	if(BT){
		InorderTraversal(BT->Left);
		printf(" %d", BT->Data);
		InorderTraversal(BT->Right);
	}
}
/* 你的代码将被嵌在这里 */
BinTree Insert( BinTree BST, ElementType X ){  //!!!这个插入递归后都会进入if添加新结点,无法返回根结点,插入后不会返回到根节点 
    if(!BST){
        BinTree B = (Position)malloc(sizeof(Position));
        B->Data = X;
        B->Left = NULL;
        B->Right = NULL;
        BST = B;
    }else if(X < BST->Data){
        BST->Left = Insert(BST->Left, X);  //借鉴了大佬的方法 ,这样返回的形式是BST->Left->Right->……, BST仍然指向根结点 
    }else{
        BST->Right = Insert(BST->Right, X);
    }
    return BST;   //要返回根结点,每次插入才能从头开始查询 
}

BinTree Delete( BinTree BST, ElementType X ){   
    BinTree T, S, F=NULL, P;   //F= NULL 因为如果是判断是否为根节点,如果是根节点,不再定义F, 需要初始化 
    T = BST;
    while(T){
        if(T->Data == X) break;
        F = T;
        if(T->Data > X) T = T->Left;
        else T = T->Right;
    }
    if(!T){
        printf("Not Found\n");
        return BST;
    }
    P = T;
    if(T->Left && T->Right){
        S = T->Left;
        while(S->Right){
            P = S;
            S = S->Right;
        }
        T->Data = S->Data;
        if(P != T){
            P->Right = S->Left;
        }else{
            P->Left = S->Left;
        }
    }
    else if(!T->Left){
        T = T->Right;
    }else{
        T = T->Left;
    }
    if(!F) BST = T;
    else if(P == F->Left) F->Left = T;
    else F->Right = T;
    return BST;
}
Position Find( BinTree BST, ElementType X ){
	if(BST){                                       //一切操作都是树非空的条件下 
    	if(BST->Data == X){
        	return BST;
    	}else if(X < BST->Data){
        	return Find(BST->Left, X); //递归注意 ,这里不返回上一个答案的话,就会一直返回到最开始,相当于返回根节点,无效搜索,下面的递归同样 
    	}else{
        	return Find(BST->Right, X);
    	}
	}
    	return NULL;
}
Position FindMin( BinTree BST ){
    if(BST){
    	if(BST->Left != NULL){
        return FindMin(BST->Left);   
    }
    	return BST;
	}
}
Position FindMax( BinTree BST ){
    if(BST){
    	if(BST->Right!=NULL){
        return FindMax(BST->Right);
    }
    	return BST;
	}
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值