CodeForces - 1234B1 Social Network (easy version)

CodeForces - 1234B1 Social Network (easy version)

题目

The only difference between easy and hard versions are constraints on n and k .
You are messaging in one of the popular social networks via your smartphone. Your smartphone can show at most k most recent conversations with your friends. Initially, the screen is empty (i.e. the number of displayed conversations equals 0).

Each conversation is between you and some of your friends. There is at most one conversation with any of your friends. So each conversation is uniquely defined by your friend.

You (suddenly!) have the ability to see the future. You know that during the day you will receive nn messages, the i-th message will be received from the friend with ID idi (1≤idi≤109).

If you receive a message from idi in the conversation which is currently displayed on the smartphone then nothing happens: the conversations of the screen do not change and do not change their order, you read the message and continue waiting for new messages.

Otherwise (i.e. if there is no conversation with idi on the screen):

Firstly, if the number of conversations displayed on the screen is k, the last conversation (which has the position k) is removed from the screen.
Now the number of conversations on the screen is guaranteed to be less than k and the conversation with the friend idiidi is not displayed on the screen.
The conversation with the friend idiidi appears on the first (the topmost) position on the screen and all the other displayed conversations are shifted one position down.

Your task is to find the list of conversations (in the order they are displayed on the screen) after processing all n messages.


Input

The first line of the input contains two integers n and k (1≤n,k≤200) — the number of messages and the number of conversations your smartphone can show.

The second line of the input contains nn integers id1 ,id2 ,…,idn (1≤idi ≤109), where idi is the ID of the friend which sends you the i-th message.


Output

In the first line of the output print one integer m (1≤m≤min(n,k)) — the number of conversations shown after receiving all n messages

In the second line print mm integers ids1,ids2,…,idsm, where idsi should be equal to the ID of the friend corresponding to the conversation displayed on the position i after receiving all n messages.


Sample Input

7 2
1 2 3 2 1 3 2

Sample Output

2
2 1 

Sample Input

10 4
2 3 3 1 1 2 1 2 3 3

Sample Output

3
1 3 2 

题目大意:
一共有n条信息,屏幕上只能显示k个好友的信息,如果该好友的信息已经在屏幕上则不发生任何变化,否则将最早的一条好友信息顶掉,新的好友信息进入屏幕。

题目分析:

对于简单版的 ,我们还是比较容易过的 , 我们只需要 设置两个数组分别 存放 屏幕上的 朋友的ID ,和 朋友来信的ID的顺序
用两个循环嵌套,暴力扫 存放屏幕上朋友 ID的数组 ,如果有 就不执行操作,如果没有 就每个向后移动,然后放在最前面,
对于简单版 是不会超时的,但是复杂版就 不可以暴力扫了,
复杂版请移步 : CodeForces - 1234B2 Social Network (hard version)

AC代码

 #include <stdio.h>
int main()
{
	int n,k,i=0,j=0,x=0,c=0;
	scanf("%d%d",&n,&k);
	int id[n],l[k]={0};
	for(i=0;i<n;i++)
	scanf("%d",&id[i]);
	for (i=0;i<n;i++)
	{
		for (;j<k;)
			if (l[j]!=id[i])
			{
			j++;
			x++;
			}
			else
			 j++;
		j=0;
		if(x==k)//x与k比较 是判断 屏幕上有没有 的条件,
		{
			for(j=k-1;j>0;j--)
			l[j]=l[j-1];
			l[0]=id[i];
		}
			x=0;			 
	}
	for (j=0;j<k;j++)
	if(l[j]>0)
	c++;
	printf("%d\n",c);
	for (j=0;j<k;j++)
	if(l[j]>0)
	printf("%d ",l[j]);
	
	return 0;	 	
	}

我来要赞了,如果觉得解释还算详细,可以学到点什么的话,点个赞再走吧
欢迎各位路过的dalao 指点,提出问题。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值