POJ-2184

题目

Description

“Fat and docile, big and dumb, they look so stupid, they aren’t much
fun…”

  • Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si’s and, likewise, the total funness TF of the group is the sum of the Fi’s. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.

Input

  • Line 1: A single integer N, the number of cows

  • Lines 2…N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.

Output

  • Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8
Hint

OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.

题意

有N头(1 <= N <= 100)牛每头牛有两个值:机敏度Si(-1000 <= Si <= 1000)和乐趣度Fi(- 1000 <= Fi <= 1000)
求机敏度和乐趣度的最大和。

分析

「0-1 背包问题」对于每个对象(🐂)有取和不取两种状态。我们不妨把乐趣度看成体积,机敏度成价值。
因此乐趣度的和的取值范围为[-100000, 100000] 为了便于操作我们可以将这个范围映射到[0, 200000] 上。

接下来根据机敏度的正负进行不同的处理:
如果是正数,对于每头牛有两种状态(选和不选)按01背包来。从状态转移方程dp[j] = max(dp[j], dp[j-s[i]]+f[i]) 看,每次更新都是用未加入第 i 头牛的值来更新。因此我们采用从 j 最大值开始往回更新。
当机敏度为负值时上一个状态的机敏度的和是大于当前的。因此正向循环即可。

AC Code

#include<iostream>
#include<vector>
using namespace std;
typedef  long long int ll;
const int inf = 0x3fffffff;

int dp[200003];

int main()
{
    int n;
    cin >> n;
    int s[103], f[103];
    for (int i = 0; i < n; ++i) {
        cin >> s[i] >> f[i];
    }
    fill(dp, dp+200003, -inf);
    dp[100000] = 0;
    for (int i = 0; i < n; ++i) {
        if (s[i]<0 && f[i]<0) continue;
        if (s[i] > 0) {
        	// 逆向循环
            for (int j = 200000; j >= s[i]; --j) {
                if (dp[j-s[i]] > -inf) // 是否存在对应的机敏度
                    dp[j] = max(dp[j], dp[j-s[i]]+f[i]);
            }
        } else {
        	// 正向循环
            for (int j = s[i]; j <= 200000 + s[i]; ++j) {
                if (dp[j-s[i]] > -inf)
                    dp[j] = max(dp[j], dp[j-s[i]]+f[i]);
            }
        }
    }
    int ans = -inf;
    for (int i = 100000; i < 200001; ++i) {
        if (dp[i] >= 0)
            ans = max(ans, dp[i]+i-100000); // 机敏度和乐趣度的和取max
    }
    cout << ans;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值