寒假集训数论H / POJ - 2689

题目
The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).
Input
Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.
Output
For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.
Sample Input
2 17
14 17
Sample Output
2,3 are closest, 7,11 are most distant.
There are no adjacent primes.
题目大意
求区间[L,R]之间的相邻素数差的最大值和最小值。
(R-L<=1000000,1<=L<R<=2147483647)
解题思路
先求1~sqrt( R )的素数表(因为如果一个数x是合数,那么它能被小于等于sqrt(x)的素数筛掉),再用这个素数表去筛区间[L,R]。
代码

#include <cstdio>
#include <cstring>
#include <cmath>
#include <iostream>
using namespace std;
bool vis[1010101],v[1010101];
int p[101010];
void get_prime(int x)
{
	memset(vis,false,sizeof(vis));
	p[0]=0;
	double xx=x; 
	int len=sqrt(xx);
	for (int i=2;i<=len;i++)
	  {
	  	if (!vis[i]) p[++p[0]]=i;
	  	for (int j=1;j<=p[0];j++)
	  	  {
	  	  	if (i*p[j]>len) break;
	  	  	vis[i*p[j]]=true;
	  	  	if (i%p[j]==0) break;
	  	  }
	  }
}
void check(int L,int R)
{
	memset(v,false,sizeof(v));
	for (int j=1;j<=p[0];j++)
	  {
	  	if (R/p[j]==1) break;
	  for (int i=L/p[j];i<=R/p[j];i++)
	    if (i*p[j]>=L && i!=1) v[i*p[j]-L]=true;
	  }
	int a=0,b=0,mi=999999999,mx=-999999999,mia,mib,mxa,mxb;    
	for (int i=0;i<=R-L;i++)
	if (!v[i])
	  {
	    if (a==0) a=i+L;
	    else 
	    {
	    	if (b==0) b=i+L;
	    	else
	    	{
	    	a=b;
	    	b=i+L;
	        }
	    	if (b-a<mi) 
	    	{
	    		mi=b-a;
	    		mia=a;
	    		mib=b;
	    	}
	    	if (b-a>mx)
	    	{
	    		mx=b-a;
	    		mxa=a;
	    		mxb=b;
	    	}
	    }
	  }
	 if (mx==-999999999) 
	 printf("There are no adjacent primes.\n");
	 else
	 printf("%d,%d are closest, %d,%d are most distant.\n",mia,mib,mxa,mxb);
}
int main()
{
	int L,R;
	get_prime(2147483647);
	while (cin>>L>>R)
	{
		if (L==1) L++;
		check(L,R);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值