看病要排队

看病要排队这个是地球人都知道的常识。
不过经过细心的0068的观察,他发现了医院里排队还是有讲究的。0068所去的医院有三个医生(汗,这么少)同时看病。而看病的人病情有轻重,所以不能根据简单的先来先服务的原则。所以医院对每种病情规定了10种不同的优先级。级别为10的优先权最高,级别为1的优先权最低。医生在看病时,则会在他的队伍里面选择一个优先权最高的人进行诊治。如果遇到两个优先权一样的病人的话,则选择最早来排队的病人。

现在就请你帮助医院模拟这个看病过程。
Input
输入数据包含多组测试,请处理到文件结束。
每组数据第一行有一个正整数N(0<N<2000)表示发生事件的数目。
接下来有N行分别表示发生的事件。
一共有两种事件:
1:“IN A B”,表示有一个拥有优先级B的病人要求医生A诊治。(0<A<=3,0<B<=10)
2:“OUT A”,表示医生A进行了一次诊治,诊治完毕后,病人出院。(0<A<=3)
Output
对于每个"OUT A"事件,请在一行里面输出被诊治人的编号ID。如果该事件时无病人需要诊治,则输出"EMPTY"。
诊治人的编号ID的定义为:在一组测试中,"IN A B"事件发生第K次时,进来的病人ID即为K。从1开始编号。
Sample Input
7
IN 1 1
IN 1 2
OUT 1
OUT 2
IN 2 1
OUT 2
OUT 1
2
IN 1 1
OUT 1
Sample Output
2
EMPTY
3
1
1

#include <stdio.h>
#include <stdio.h>
#include <string.h>
struct node
{
    int id;
    int priority;
    struct node* next;
};
typedef struct node* nodep;
nodep create();
void in(nodep head,int id_,int priority_);
int out(nodep head);
int main()
{
    int n;
    while(scanf("%d",&n) != EOF)
    {
        int id_count = 1;
        nodep doctor[4];
        for(int i = 1;i < 4;i++)
            doctor[i] = create();
        while(n)
        {
            char setType[4];
            scanf("%s",setType);
            if(!strcmp(setType,"IN"))
            {
                int patient_,doctor_;
                scanf("%d%d",&doctor_,&patient_);
                in(doctor[doctor_],id_count,patient_);
                id_count++;
            }
            else
            {
                int doctor_;
                scanf("%d",&doctor_);
                if(doctor[doctor_]->next == NULL)
                    printf("EMPTY\n");
                else
                    printf("%d\n",out(doctor[doctor_]));
            }
            n--;
        }

    }
    return 0;
}
void in(nodep head,int id_,int priority_)
{
    nodep newNode = (nodep)malloc(sizeof(struct node));
    newNode->id = id_;
    newNode->priority = priority_;
    newNode->next = NULL;
    nodep p0 = head,p = head;
    while(p)
    {
        p0 = p;
        p = p->next;
    }
    p0->next = newNode;
}
int out(nodep head)
{
    int max = 1;
    nodep p = head->next;
    while(p)
    {
        if(p->priority > max)
            max = p->priority;
        p = p->next;
    }
    nodep p0 = head;p = head->next;
    while(p->priority != max)
    {
        p0 = p;
        p = p->next;
    }
    int temp = p->id;
    p0->next = p->next;
    free(p);
    return temp;
}
nodep create()
{
    nodep head = (nodep)malloc(sizeof(struct node));
    head->next = NULL;
    return head;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值