SWUST OJ#287 one+two

题目描述
读入两个小于100的正整数A和B,计算A+B。需要注意的是:A和B的每一位数字由对应的英文单词给出。

输入
测试输入包含若干测试用例,每个测试用例占一行,格式为"A + B =",相邻两字符串有一个空格间隔。当A和B同时为0时输入结束,相应的结果不要输出。

输出
对每个测试用例输出1行,即A+B的值。

样例输入
复制
one + two =
three four + five six =
zero seven + eight nine =
zero + zero =
样例输出
3
90
96

#include<stdio.h>
#include<string.h>
int num1(char a[])//num1和num2函数是一样的,构造两个函数主要是为了将输入的两个数字分清楚。目的将字符换为数字
{
    if(strcmp(a,"one")==0)
        return 1;
    else if(strcmp(a,"two")==0)
        return 2;
    else if(strcmp(a,"three")==0)
        return 3;
    else if(strcmp(a,"four")==0)
        return 4;
    else if(strcmp(a,"five")==0)
        return 5;
    else if(strcmp(a,"six")==0)
        return 6;
    else if(strcmp(a,"seven")==0)
        return 7;
    else if(strcmp(a,"eight")==0)
        return 8;
    else if(strcmp(a,"nine")==0)
        return 9;
    else if(strcmp(a,"zero")==0)
        return 0;
}
int num2(char a[])
{
    if(strcmp(a,"one")==0)
        return 1;
    else if(strcmp(a,"two")==0)
        return 2;
    else if(strcmp(a,"three")==0)
        return 3;
    else if(strcmp(a,"four")==0)
        return 4;
    else if(strcmp(a,"five")==0)
        return 5;
    else if(strcmp(a,"six")==0)
        return 6;
    else if(strcmp(a,"seven")==0)
        return 7;
    else if(strcmp(a,"eight")==0)
        return 8;
    else if(strcmp(a,"nine")==0)
        return 9;
    else if(strcmp(a,"zero")==0)
        return 0;
}
int main()//注意题的前提是两个小于100的数,意思就是两个两位数
{

    char a[20];//这里的a数组不止指代输入的字符串,还有“+”和“=”,“ ”等
    int num1(char a[]);
    int num2(char a[]);
    while(1)
    {
        int sum=0,sum1=0,sum2=0;
        scanf("%s",a);//这里a是第一个字符串
        sum1=num1(a);//将字符换为数字
        scanf("%s",a);//输入第二个字符串
        if(strcmp(a,"+")!=0)//判断第二个字符串是否是"+",即判断第一个数字是否是两位数
        {
            sum1=sum1*10+num1(a);//不是加号则第一个数字是两位数
            scanf("%s",a);//这里a是“ ”
        }
        scanf("%s",a);
        sum2=num2(a);
        scanf("%s",a);
        if(strcmp(a,"=")!=0)
        {
            sum2=sum2*10+num2(a);
            scanf("%s",a);
        }
        sum=sum1+sum2;
        if(sum==0)
            return 0;//即sum1==0&&sum2==0
        else
            printf("%d\n",sum);
    }
    return 0;
}

  • 7
    点赞
  • 13
    收藏
    觉得还不错? 一键收藏
  • 7
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 7
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值