HDU-2147 kiki‘s game

Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can’t make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?

Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

Output
If kiki wins the game printf “Wonderful!”, else “What a pity!”.

Sample Input
5 3
5 4
6 6
0 0
Sample Output
What a pity!
Wonderful!
Wonderful!

题目的意思是说 给出n*m的表盘,kiki作为先手要从右上角走到左下角,每次能向左走、向下走、向左下走、若能必胜输出“Wonderful!”,若必输则输出“What a pity!”。
然后可以多画几种情况来看一下:
在这里插入图片描述
这里用P表示kiki必胜的情况,N表示必败的情况。

若n=1,m=1,为图示表格右上角的位置,kiki已经不能走了,所以为P;
若n=2,m=1,为图示表格右上角“日”字形的两块,kiki作为先手要走到下面一块,此时为必胜。
…………
同理画出5*5的表格之后可以发现规律:当n、m有任意一个为偶数时,kiki都是必胜的。

#include<iostream>
using namespace std;
int main()
{
	int n,m;
	while(cin>>n>>m&&n&&m)
	{
		if(n%2==0||m%2==0)cout<<"Wonderful!"<<endl;
		else cout<<"What a pity!"<<endl;
	}
	return 0;
} 
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值