[HDU](2147)kiki's game ---找规律博弈(博弈)

kiki's game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/10000 K (Java/Others)
Total Submission(s): 11242    Accepted Submission(s): 6815


Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in her mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
 

Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

 

Output
If kiki wins the game printf "Wonderful!", else "What a pity!".
 

Sample Input
  
  
5 3 5 4 6 6 0 0
 

Sample Output
  
  
What a pity! Wonderful! Wonderful!
 

解题新知:首先这道题自己找到了一个规律,根据数据推测的233333。即(n*m-1)%2!=0  kiki赢,这算是碰巧了,看了别人的题解才知道自己这个其实是原题必胜态的一个变式。

PNPNPNP
NNNNNNN
PNPNPNP
NNNNNNN
PNPNPNP
NNNNNNN
PNPNPNP
如图这是前辈画的NP图,我就按照自己的理解,说一下,题意是说在右上角开始(1,m)下棋者可以向左,向下,向左下三个方向走一步。kiki先下,那么如果kiki要赢,那么右上角(1,m)处应为P。(1,m-1),(2,m),(2,m-1)处为N。如果ZZ想赢那么他要使(3,m-2)为P。按照规律,其实就组成了这幅图。由图中规律可知,当行m为偶数或者列n为偶数时,N状态,即先下者胜利。








AC代码:
#include<iostream>
using namespace std;
int main()
{
    int n,m;
    while(cin>>n>>m && m &&n)
    {
        int flag=n*m;
        if(flag%2!=0)
            cout<<"What a pity!"<<endl;
        else
            cout<<"Wonderful!"<<endl;
    }
    return 0;
}









评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值