杭电1020(JAVA版)

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 74151    Accepted Submission(s): 32828


 
Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 
 
Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 
 
Output
For each test case, output the encoded string in a line.
 
 
Sample Input
2
ABC
ABBCCC
 
Sample Output
ABC
A2B3C
 

思路还是很简单的,找是不是有重复的字符,有多少个 ,如果只有一个就不显示数字,如果多个就显示出具体有几个。代码如下:

import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner scanner=new Scanner(System.in);
		int N=scanner.nextInt();
		for(int i=0;i<N;i++) {
			String str=scanner.next();
			int k=1;
			for(int j=1;j<str.length();j++) {
				if(cf(str.charAt(j-1), str.charAt(j))) {
					k++;
				}
				else {
					if(k==1) {
						System.out.print(str.charAt(j-1));
					}
					else {
						System.out.print(k+""+str.charAt(j-1));
						k=1;
					}
				}
			}
			if(k==1) {
				System.out.println(str.charAt(str.length()-1));
			}
			else {
				System.out.println(k+""+str.charAt(str.length()-1));
			}
		}
		scanner.close();
	}
    //判断前后两个字符是否相等
	public static boolean cf(char a,char b) {
		if(a==b) return true;
		return false;
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值