杭电1021(JAVA版)

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 97537    Accepted Submission(s): 43162


 
Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 
 
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 
 
Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 
 
Sample Input
0
1
2
3
4
Sample Output
no
no
yes
no
no
no

 这道题就是看f(n)能不能被3整除,一开始用了递归算法,超时了,无奈,找规律吧。能得出在2,6,10,14,18。。。时f(n)能够被3整除,就易推出,(n-2)%4==0的时候就会输出yes。

import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner scanner=new Scanner(System.in);
		while(scanner.hasNext()) {
			int n=scanner.nextInt();
			if((n-2)%4==0) System.out.println("yes");
			else System.out.println("no");
		}
		scanner.close();
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值
>