题目 1637: 蓝桥杯算法训练VIP-斜率计算

题目描述

输入两个点的坐标,即p1  =  (x1,  y1)和p2=(x2,  y2),求过这两个点的直线的斜率。如果斜率为无穷大输出“INF”。

输入

输出

样例输入

1 2
1 4

样例输出

INF
package parctice;

import java.util.Scanner;
public class ph1637 {
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		int[] aa=new int[2];
		int[] bb=new int[2];
		for (int i = 0; i < aa.length; i++) {
			aa[i]=sc.nextInt();
		}
		for (int i = 0; i < bb.length; i++) {
			bb[i]=sc.nextInt();
		}
		if (aa[0]==bb[0]) {
			System.out.println("INF");
		}else {
			System.out.println((bb[1]-aa[1])/(bb[0]-aa[0]));
		}
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值