P1001: A + B Problem II

P1001: A + B Problem II

题目描述
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
样例输入

2
1 2
112233445566778899 998877665544332211

样例输出

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
#include<iostream>
#include<cstring>//或者#include<string.h>,C++这两个都行,而C只能是.h
using namespace std;

int JiaFa(string num1, string num2, char num[])
{
	int len1 = num1.length(), len2 = num2.length();
	int i = len1-1,j=len2-1,k=0;
	int yuxiang = 0;
	while(i>=0||j>=0)
	{
		if (i >=0 && j >= 0)
		{
			num[k++] = ((num1[i] - '0') + (num2[j] - '0') + yuxiang) % 10 + '0';
			yuxiang = ((num1[i] - '0') + (num2[j] - '0') + yuxiang) / 10;
			i--;
			j--;
		}
		else if (i <0)
		{
			num[k++] = ((num2[j] - '0') + yuxiang) % 10+'0';
			yuxiang= ((num2[j] - '0') + yuxiang) / 10;
			j--;
		}
		else
		{
			num[k++] = ((num1[i] - '0') + yuxiang) % 10 + '0';
			yuxiang = ((num1[i] - '0') + yuxiang) / 10;
			i--;
		}
	}
	if (yuxiang)
	{
		num[k] = yuxiang + '0';
		num[k + 1] = '\0';
	}
	else
		num[k] = '\0';
	{
		int i = 0, j = strlen(num)-1;
		for (; i < j; i++, j--)
		{
			char temp = num[i];
			num[i] = num[j];
			num[j] = temp;
		}
	}
	return 1;
}


int main()
{
	string num1[100], num2[100];
	char num[100][10000];
	int n,i;

	cin >> n;
	for (i = 0; i < n; i++)
		cin >> num1[i] >> num2[i];
	for (i = 0; i < n; i++)
	{
		JiaFa(num1[i],num2[i],num[i]);
		cout << "Case " << i+1 << ":" << endl;
		cout << num1[i] << " + " << num2[i] << " = " << num[i] << endl;
		cout << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值