2019 GDUT 新生 专题Ⅰ A题

A 尺取/POJ3061

题目
A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3

题目大意是在所给的N个元素中,找出连续元素的子序列的最小长度并使他们的和大于等于S。

思路
简单的尺取模板即可。

代码

#include <cstdio>
#include <cstring>
const int inf=100005;
int a[100005];
int main(){
	int n,s,t;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&n,&s);
		for(int i=0;i<n;i++){
			scanf("%d",&a[i]);
		}
		int p1=0,p2=0;
		int sum=a[0],min=inf;
		while(p2<n){
			if(sum>=s){
				if(min>p2-p1+1) min=p2-p1+1;
				sum-=a[p1++];
			}
			if(sum<s){
				p2++;
				sum+=a[p2];
			}
		}
		if(min==inf) printf("0\n");
		else
		printf("%d\n",min);
	}
	return 0;
}

题目链接

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值