hdu1072 -- Nightmare(BFS)

hdu1072 – Nightmare(BFS)

Problem Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius’ start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:

  1. We can assume the labyrinth is a 2 array.
  2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
  3. If Ignatius get to the exit when the exploding time turns to 0, he can’t get out of the labyrinth.
  4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can’t use the equipment to reset the bomb.
  5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
  6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius’ start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius’ target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

Sample Input

3
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
5 8
1 2 1 1 1 1 1 4
1 0 0 0 1 0 0 1
1 4 1 0 1 1 0 1
1 0 0 0 0 3 0 1
1 1 4 1 1 1 1 1

Sample Output

4
-1
13

(第一次写BFS,把我写吐了。。)
说一下我的理解:
题目要求从起点走到终点的最小步数,显而易见要BFS,这里要注意这题是可以往回走的(如样例三),所以说这题是不能标记走过的路的,但是没有了限制条件该怎么办呢?如果要往回走的话只有一个目的就是到达4重置时间,所以说在到达4后,4已经失去了利用价值,无论走多少遍结果都是一样的,所以到达4后将4变为0.
以下为ac代码

#include<iostream>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <map>
#include <queue>
#include <set>
#include <string>
#include <vector>
using namespace std;
typedef long long ll;
int n, m;
int vis[10][10];
int dx[4] = {-1, 0, 1, 0}, dy[4] = {0, 1, 0, -1};
int maze[10][10];
struct node{
    int x;
    int y;
    int step;
    int time;
}s;
void bfs(){
    queue <node> q;
    q.push(s);
    node p1,p2;
    while(!q.empty()){
        p1=q.front();
        q.pop();
        for(int i=0;i<4;i++){
             p2.step = p1.step+1;
             p2.time = p1.time-1;
             p2.x = p1.x+dx[i];
             p2.y = p1.y+dy[i];
             if(p2.x>0&&p2.x<=n&&p2.y>0&&p2.y<=m&&maze[p2.x][p2.y]!=0&&p2.time>0){
                if(maze[p2.x][p2.y] == 3){
                    cout << p2.step << endl;
                    return;
                }
                if(maze[p2.x][p2.y] == 4){
                    p2.time = 6;
                    maze[p2.x][p2.y] = 0;
                }
                q.push(p2);
                //cout << p2.x << ' ' << p2.y << ' ' << p2.step << endl;
                //cout << p2.time << endl;
             }
       }
    }
    cout << -1 << endl;
    return;
}
int main(){
    int t;
    scanf("%d", &t);
    while(t--){
        memset(maze,0,sizeof(maze));
        scanf("%d %d", &n, &m);
        for(int i = 1; i <= n; i++){
            for(int j = 1; j <= m; j++){
                scanf("%d", &maze[i][j]);
                if(maze[i][j] == 2){
                    s.x=i;
                    s.y=j;
                    s.step=0;
                    s.time=6;
                }
            }
        }
        bfs();
    }
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值