Common Subsequence(POJ-1458)

Common Subsequence

题目

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input

abcfbc abfcab
programming contest
abcd mnp
Sample Output

4
2
0

代码

  这道题的思路和之前写过的最长递增子序列、最大连续子序列和类似。关键是找到状态转移方程。这道题的状态转移方程也比较简单,可以直接看代码(还是用了三种方法依次解决)

#include <iostream>
#include <cstring>

using namespace std;

const int MAXN = 1010;

char str1[MAXN];
char str2[MAXN];

//朴素递归
int func1(int i,int j){
    int answer;
    //注意输入是从str+1开始输入的,所以i或j等于0就相当于str1[i]或str2[j]前面为空串了
    //有一个为空串,自然两个串的最长公共子序列为0
    if(i == 0 || j == 0){
        answer = 0;
    }
    else if(str1[i] == str2[j]){
            answer = func1(i-1,j-1) + 1;
    }
    else{
        answer = max(func1(i-1,j),func1(i,j-1));
    }
    return answer;
}

//备忘录法
int memo[MAXN][MAXN];
int func2(int i,int j){
    int answer;
    if(memo[i][j] != -1){
        answer = memo[i][j];
    }else{
        if(i == 0 || j == 0){
            answer = 0;
        }
        else if(str1[i] == str2[j]){
            answer = func2(i-1,j-1) + 1;
        }
        else{
            answer = max(func2(i-1,j),func2(i,j-1));
        }
    }
    memo[i][j] = answer;
    return answer;
}

//自底向上递推
int dp[MAXN][MAXN];
void func3(int n,int m){
    int answer;
    for(int i = 0; i<=n;i++){
        for(int j = 0; j<=m;j++){
            if(i == 0 || j == 0){
                answer = 0;
            }else if(str1[i] == str2[j]){
                answer = dp[i-1][j-1] + 1;
            }else{
                answer = max(dp[i-1][j],dp[i][j-1]);
            }
            dp[i][j] = answer;
        }
    }
    return;
}

int main()
{
    while(scanf("%s%s",str1+1,str2+1)!=EOF){
        int n = strlen(str1+1);
        int m = strlen(str2+1);
        //对于最长公共子序列,最大的一定是func(n,m)
//        for(int i = 0; i<=n ;i++)
//            for(int j = 0; j<=m ;j++){
//                memo[i][j] = -1;
//            }
//        int maximun = func2(n,m);
        for(int i = 0; i<=n ;i++)
              for(int j = 0; j<=m ;j++){
                  dp[i][j] = 0;
              }
        func3(n,m);
        int maximun = dp[n][m];
        printf("%d\n",maximun);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值