7-1 两个有序链表序列的交集 (20分)

已知两个非降序链表序列S1与S2,设计函数构造出S1与S2的交集新链表S3。
输入格式:

输入分两行,分别在每行给出由若干个正整数构成的非降序序列,用−1表示序列的结尾(−1不属于这个序列)。数字用空格间隔。
输出格式:

在一行中输出两个输入序列的交集序列,数字间用空格分开,结尾不能有多余空格;若新链表为空,输出NULL。
输入样例:

1 2 5 -1
2 4 5 8 10 -1

输出样例:

2 5

这道题其实就是将创建链表和数值比较结合在了一起,并不是很难实现。

代码实现:

#include <iostream>
using namespace std;

struct node
{
	int data;
	node* next;
};

node* creatlist();

int main()
{
	int cnt = 0; //cnt用于记录大小相同的数字的个数,和数组增长
	int num[10000] = { 0 };
	node* L1 = creatlist(), * L2 = creatlist();

	while (L1 && L2)
	{
		if (L1->data < L2->data) //只有在L1对应的数据小于L2时才进入L2查找(双指针法实现)
			L1 = L1->next;
		else if (L1->data > L2->data)
			L2 = L2->next;
		else
		{
			num[cnt++] = L1->data;
			L1 = L1->next;
			L2 = L2->next;
		}
	}

	if (!cnt)
		cout << "NULL";
	else
	{
		cout << num[0];
		for (int i = 1; i < cnt; i++)
			cout << ' ' << num[i];
	}

	return 0;
}

node* creatlist() //使用尾插法创建新链表,没有头节点。
{
	int data;
	node* head, * tail, * temp;
	head = tail = nullptr;

	while (cin >> data && data != -1)
	{
		temp = new node;
		temp->data = data;
		temp->next = nullptr;
		if (!head)
			head = tail = temp;
		else
		{
			tail->next = temp;
			tail = temp;
		}
	}
	return head;
}
  • 2
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值