6-3 删除单链表偶数节点 (20分)

本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:

struct ListNode {
int data;
struct ListNode *next;
};

函数接口定义:

struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );

函数createlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。

函数deleteeven将单链表head中偶数值的结点删除,返回结果链表的头指针。
裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

struct ListNode {
int data;
struct ListNode *next;
};

struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head )
{
struct ListNode *p = head;
while § {
printf("%d “, p->data);
p = p->next;
}
printf(”\n");
}

int main()
{
struct ListNode *head;

head = createlist();
head = deleteeven(head);
printlist(head);

return 0;

}

输入样例:

1 2 2 3 4 5 6 7 -1

输出样例:

1 3 5 7

关于这类问题的解法:
这类问题实际上是,按照条件构建一个新的链表。
就拿本题举例来说吧,我们可以遍历已知链表,找出结点整数域为奇数的结点,将他们分别连接到新的头指针上,按照题目构建出一个新的链表。(这里没有按照题目要求创建一个带头节点的链表~)

代码实现:

struct ListNode* createlist()//使用尾插法按照输入顺序创建不带头节点的链表
{
    {
        int data;
        struct ListNode* head, * tail, * temp;
        head = tail = NULL;//带头节点则是 head = tail = (struct ListNode*)malloc(sizeof(struct ListNode));

        while (scanf("%d", &data) && data != -1)
        {
            temp = (struct ListNode*)malloc(sizeof(struct ListNode));
            temp->data = data;
            temp->next = NULL;
            if (!head)
                head = tail = temp;
            else
            {
                tail->next = temp;
                tail = temp;
            }
        }
        return head;
    }
}

struct ListNode* deleteeven(struct ListNode* head)
   {
        struct ListNode* temp = head, * newhead = NULL, * tail = NULL;

        for (; temp; temp = temp->next)
        {
            if (!newhead && temp->data % 2)
                newhead = tail = temp;
            else if (newhead && temp->data % 2)
            {
                tail->next = temp;
                tail = temp;
            }
        }

        if (tail)
            tail->next = NULL;
        return newhead;
    }

  • 3
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值