POJ 1029真假硬币

该问题描述了一个关于寻找假硬币的数学挑战。在一组硬币中,只有一个假硬币重量不同,其余硬币重量相同。通过一系列天平称量,需要确定假硬币的编号。输入包含称量的次数和每次称量的详细信息,包括硬币编号和结果(大于、小于或等于)。程序需要分析这些信息并确定假硬币的编号,如果无法确定则输出0。给出的解题思路是通过统计每个硬币在较轻或较重侧出现的次数来判断假硬币。如果存在多个候选硬币且无法区分,则输出0。
摘要由CSDN通过智能技术生成

POJ 1029

False coin

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 20114Accepted: 5682

Description

The “Gold Bar”bank received information from reliable sources that in their last group of N coins exactly one coin is false and differs in weight from other coins (while all other coins are equal in weight). After the economic crisis they have only a simple balance available (like one in the picture). Using this balance, one is able to determine if the weight of objects in the left pan is less than, greater than, or equal to the weight of objects in the right pan.
In order to detect the false coin the bank employees numbered all coins by the integers from 1 to N, thus assigning each coin a unique integer identifier. After that they began to weight various groups of coins by placing equal numbers of coins in the left pan and in the right pan. The identifiers of coins and the results of the weightings were carefully recorded.
You are to write a program that will help the bank employees to determine the identifier of the false coin using the results of these weightings.

Input

The first line of the input file contains two integers N and K, separated by spaces, where N is the number of coins (2<=N<=1000 ) and K is the number of weightings fulfilled (1<=K<=100). The following 2K lines describe all weightings. Two consecutive lines describe each weighting. The first of them starts with a number Pi (1<=Pi<=N/2), representing the number of coins placed in the left and in the right pans, followed by Pi identifiers of coins placed in the left pan and Pi identifiers of coins placed in the right pan. All numbers are separated by spaces. The second line contains one of the following characters: ‘<’, ‘>’, or ‘=’. It represents the result of the weighting:
‘<’ means that the weight of coins in the left pan is less than the weight of coins in the right pan,
‘>’ means that the weight of coins in the left pan is greater than the weight of coins in the right pan,
‘=’ means that the weight of coins in the left pan is equal to the weight of coins in the right pan.

Output

Write to the output file the identifier of the false coin or 0, if it cannot be found by the results of the given weightings.

Sample Input

5 3
2 1 2 3 4
<
1 1 4
=
1 2 5
=

Sample Output

3

Source

Northeastern Europe 1998

题目大意

​ 给你n个硬币,k组称量结果。在这n个硬币中有一个是假的,他的重量跟其他的不一样(不知道大小),真硬币的重量都相同。每组第一个数字代表左右放置硬币的数量,后面则是硬币的编号,每组后面的符号则是称量结果。问能不能确定哪个是假币,如果不能输出0.

解题思路
假币出现的次数一定跟非等号数量相等,而且假币一定全部出现在同一边,那么只需要用一个数组记录出现在两边的次数就很容易判断了。如果存在多个硬币出现的次数与非等号相等,且无法直接判断他们的真假,则直接输出0。

代码如下

#include<stdio.h>
#include<iostream>
#include<cstring>
using namespace std;
#define maxn 1005

int weight[maxn],l[maxn],r[maxn],flag[maxn];
int main()
{
    memset(weight,0,sizeof(weight));
    memset(flag,0,sizeof(flag));
    int n,k,ans=0;
    scanf("%d%d",&n,&k);
    for(int i=0; i<k; i++)
    {
        int num;
        scanf("%d",&num);
        for(int j=0; j<num; j++)
            scanf("%d",&l[j]);
        for(int j=0; j<num; j++)
            scanf("%d",&r[j]);
        char t;
        getchar();
        scanf("%c",&t);
        if(t=='=') for(int j=0; j<num; j++)
                flag[l[j]]=flag[r[j]]=1;
        else if(t=='>')
        {
            ans++;
            for(int j=0; j<num; j++)
            {
                weight[l[j]]++;
                weight[r[j]]--;
            }
        }
        else if(t=='<')
        {
            ans++;
            for(int j=0; j<num; j++)
            {
                weight[l[j]]--;
                weight[r[j]]++;
            }
        }
    }
    int sum=0,cur=0;
    for(int i=1; i<=n; i++)
    {
        if(flag[i]) continue;
        if(weight[i]==ans||weight[i]==-ans)
        {
            sum++;
            cur=i;
        }
    }
    if(sum>1) printf("0\n");
    else printf("%d\n",cur);
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值