【逻辑】1010 Radix

1010 Radix (25 分)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2 , your task is to find the radix of one number while that of the other is given.

input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:N1 N2 tag radix.Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10
结尾无空行

Sample Output 1:

2
结尾无空行

Sample Input 2:

1 ab 1 2
结尾无空行

Sample Output 2:

Impossible
结尾无空行

Code

/**
N1 N2 tag radix
6 110 1 	10(进制):N1是十进制数 
当N2是二进制时,N1 = N2 = 6 
digit is less than its radix and is chosen from the set { 0-9, a-z }  
n2 -> 
2 3 4 5 6 7 8 9..... 36(z)
坑:
可能是几亿几亿的进制
 输出尽可能小的进制 
**/
#include <iostream>
#include <cmath>
#include <cctype>
#include <algorithm>
using namespace std;
long long todecimal(string s,  long long radix){//假设是radix进制的 
	long long res = 0;
	long long len = s.length();
	for(long long i = len - 1, unit = 1; i >=0; i--, unit *= radix){
		long long num = isdigit(s[i]) ? s[i] - '0' : s[i] - 'a' + 10;
		res +=  unit * num;
	}
	return res;
}
int cmp(string s, long long radix, long long value){//假设是radix进制的 
	long long res = 0;
	long long len = s.length();
	for(long long i = len - 1, unit = 1; i >=0; i--, unit *= radix){
		if(unit > value)
			return 1;
		long long num = isdigit(s[i]) ? s[i] - '0' : s[i] - 'a' + 10;
		res +=  unit * num;
	}
	if(res > value)
		return 1;
	else if(res == value)
		return 0;
	else 
		return -1;
}
int main(){
	string n1, n2;
	long long tag, radix;
	cin>>n1>>n2>>tag>>radix;
	if(tag == 2)
		swap(n1, n2);
	char max = *max_element(n2.begin(), n2.end());
	long long value = todecimal(n1, radix);
    long long maxDigit = isdigit(max) ? max - '0' : max - 'a' + 10;
    long long low, high;
    if(todecimal(n2, maxDigit + 1) == value){
        cout<<maxDigit + 1;
        return 0;
    }  
	for( low = maxDigit + 1, high = 2147483647; low <= high; ){
        long long mid = (high + low) / 2;
		int cmpR = cmp(n2, mid, value);
		if(cmpR == 0){
			cout<<mid;
			return 0;
		}else if(cmpR == -1)//value 小于此进制转换后的数 
			low = mid + 1;//说明要增大进制,让每一位的权重更大
		else
			high = mid - 1;
	}
	 
	cout<<"Impossible";
}

开始没想到几亿几亿的进制这种2147483647这么大的进制都有,测试点7就是
还有就是要输出尽可能小的进制,最小的就是可以单位数可以表示的最大值例如a就是11进制最小就可以表示了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_Amonlisa

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值