1010 Radix (25分)【二分法】

1010 Radix (25分)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N​1​​ and N​2​​, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:


N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

 解题思路:

1.首先我们肯定得明确,将所有数字转换为10进制统一比较。

2.数据肯定会有非常大的,而且n1,n2得用string类型来存储,以便于进制转换。

3.注意我们需要尝试的进制范围(对于99这么一个数,最小的进制是10,而不会小于等于9),同时为了防止运行超时我们选择二分法。

#include<iostream>
#include<string>
#include<math.h>
#include<ctype.h>
#include<algorithm>
#define ll long long
using namespace std;

ll convertion(string num,ll radix)  //将各种进制的数转换为10进制
{
	int len = num.length();
	ll sum = 0;
	int p = 0,tmp;
	for (int i = len - 1; i >= 0; i--)
	{
		if (isdigit(num[i]))
			tmp = num[i] - '0';
		else tmp = num[i] - 'a' + 10;
		sum += tmp*pow(radix, p++);
	}
	return sum;
}

ll find(string num1, ll num2)
{
	char maxs = *max_element(num1.begin(), num1.end());
	ll low;
	if (isdigit(maxs))
		low = maxs - '0'+1;
	else low = maxs - 'a' + 11;
	ll high = max(low, num2);
	while (low <= high)
	{
		ll mid = (low + high) / 2;
		if (convertion(num1, mid) > num2||convertion(num1, mid) < 0)  //注意这个小于0的情况,即说明数据超过了长整型大小
			high = mid - 1;
		else if (convertion(num1, mid) < num2)
			low = mid + 1;
		else return mid;
	}
	return -1;
}

int main()
{
	string n1, n2;
	ll radix;
	int tag;
	cin >> n1 >> n2 >> tag>> radix;
	int flag = 0;
	if (tag == 1)
	{
		flag = find(n2, convertion(n1, radix));
	}
	else flag = find(n1, convertion(n2, radix));
	if (flag>=0)
		cout << flag << endl;
	else cout << "Impossible" << endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值