A专题-02-simulation: H - Throwing cards away I

H - Throwing cards away I

题目大意:
Given is an ordered deck of n cards numbered 1 to n with card 1 at the top and card n at the bottom. The following operation is performed as long as there are at least two cards in the deck:

         Throw away the top card and move
         the card that is now on the top of the
         deck to the bottom of the deck.

Your task is to find the sequence of discarded
cards and the last, remaining card.

输入:
Input
Each line of input (except the last) contains a
number n ≤ 50. The last line contains ‘0’ and
this line should not be processed.

输出:
Output
For each number from the input produce two
lines of output. The first line presents the sequence of discarded cards, the second line reports the last remaining card. No line will have
leading or trailing spaces. See the sample for the
expected format.

样例输入:
Sample Input
7
19
10
6
0
样例输出:
Sample Output
Discarded cards: 1, 3, 5, 7, 4, 2
Remaining card: 6
Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14
Remaining card: 6
Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8
Remaining card: 4
Discarded cards: 1, 3, 5, 2, 6
Remaining card: 4

思路:
这道题直接用STL中的queue来做就行,但是不如自己手动模拟队列的运行速度快。

AC的C++手动模拟队列代码如下:

#include<iostream>
#include<cstring>
using namespace std;
const int N = 200;
int a[N], b[N];
int main()
{
	int n;
	while (cin >> n && n)
	{
	    //top是队首,last是队尾
		int top = 1, last = n + 1;
		memset(a, 0, sizeof(a));
		memset(b, 0, sizeof(b));
		for (int i = 1; i <= n; i++)
			a[i] = i;
		int k = 1;
		while (last - top != 1)   //如果队列中元素大于一个
		{

			b[k++] = a[top++];    //把队首元素出队,丢弃
			a[last++] = a[top++]; //再把队首元素转移到队尾
		}
		cout << "Discarded cards:";
		for (int i = 1; b[i]; i++)
		{
			if (i == 1)
				cout << " " << b[i];
			else
				cout << ", " << b[i];
		}
		cout << endl;
		cout << "Remaining card: " << a[top] << endl;	}
}

AC的C++ queue代码如下

#include <iostream>
#include <queue>
using namespace std;
int main()
{
    int n;
    while(cin >> n && n) {
        queue<int> q;
        for(int i=1; i<=n; i++)
            q.push(i);
        cout << "Discarded cards:";
        bool nofirst = false;
        while(q.size() >= 2) {
            if(nofirst)
                cout << ",";
            nofirst = true;
            cout << " " << q.front();
            q.pop();
            q.push(q.front());
            q.pop();
        }
        cout << endl << "Remaining card: " << q.front() << endl;
    }
    return 0;
}

结果比较测试,手动模拟用时570ms,queue用时590ms。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值