中序和后序构建二叉树

复习到此,利用PAT的一道题作为例题,进行学习。
Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

思路:后序遍历的最后一个节点为根节点,从中序当中找到便将二叉树一分为二,那么左边中序就是inl,k-1,左边后序就是postl, postl+numleft-1,右边中序是k+1,inr,右边后序就是postl+numleft, postr-1(postr已经是根节点了)。

//1020 Tree Traversals (25 分)
#include <iostream>
#include <queue>
#include <algorithm>
using namespace std;
const int maxn = 40;
int post[maxn], in[maxn];
struct node{
	int data;
	node *lchild;
	node *rchild;
};
int n;
node *create(int postl, int postr, int inl, int inr)
{
	if(postl > postr)	return NULL;
	node *root = new node;
	root->data = post[postr];
	int k;
	for(k=inl; k<=inr; k++)
	{
		if(in[k] == post[postr])
			break;
	}
	int numleft = k-inl;
	root->lchild = create(postl, postl+numleft-1, inl, k-1);
	root->rchild = create(postl+numleft, postr-1, k+1, inr);
	return root;
}
void bfs(node *root)
{
	queue<node*> q;
	q.push(root);
	int cnt = 0;
	while(!q.empty())
	{
		node *top = q.front();
		q.pop();
		printf("%d",top->data);
		if(cnt < n)	printf(" ");
		cnt++;
		if(top->lchild != NULL)	q.push(top->lchild);
		if(top->rchild != NULL) q.push(top->rchild);
	}
}
int main()
{
	scanf("%d",&n);
	for(int i=0; i<n; i++)
	{
		scanf("%d",&post[i]);
	}
	for(int i=0; i<n; i++)
	{
		scanf("%d",&in[i]);
	}
	node *root = create(0,n-1,0, n-1);
	bfs(root);
	return 0;
} ```

  • 1
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值