Add Odd or Subtract Even

You are given two positive integers aa and bb.

In one move, you can change aa in the following way:

Choose any positive odd integer xx (x>0x>0) and replace aa with a+xa+x;
choose any positive even integer yy (y>0y>0) and replace aa with a−ya−y.
You can perform as many such operations as you want. You can choose the same numbers xx and yy in different moves.

Your task is to find the minimum number of moves required to obtain bb from aa. It is guaranteed that you can always obtain bb from aa.

You have to answer tt independent test cases.

Input

The first line of the input contains one integer tt (1≤t≤1041≤t≤104) — the number of test cases.

Then tt test cases follow. Each test case is given as two space-separated integers aa and bb (1≤a,b≤1091≤a,b≤109).

Output

For each test case, print the answer — the minimum number of moves required to obtain bb from aa if you can perform any number of moves described in the problem statement. It is guaranteed that you can always obtain bb from aa.

Sample Input

5
2 3
10 10
2 4
7 4
9 3

Sample Output

1
0
2
2
1

Note

In the first test case, you can just add 11.

In the second test case, you don’t need to do anything.

In the third test case, you can add 11 two times.

In the fourth test case, you can subtract 44 and add 11.

In the fifth test case, you can just subtract 66.

题目大意:

对两正整数进行相关操作,根据加单数减偶数奇偶性质输出ans

解题思路:

a=b时,ans为零;
a>b时,可进行“减”操作,减只能减偶数,a,b同奇或同偶ans=1,否则ans=2;
a<b时,可进行“加”操作,加只能加奇数,a,b同奇或同偶ans=2,否则ans=1。

代码如下:
#include<iostream>
#include<algorithm>
#include<cstdio>

using namespace std;

typedef long long ll;
void ss()
{
	ll a,b,ans;
	scanf("%lld%lld",&a,&b);
	if(a==b){
		ans=0;
	}
	else if(a<b){
		if((a+b)%2==1)
			ans=1;//a,b一奇一偶
		else ans=2;//a,b同为奇数或者同为偶数
	}
	else {
		if((a-b)%2==1)
			ans=2;//a>b时ans值相反
		else ans=1;
	}
	printf("%lld\n",ans);
}
void main()
{
	ll t;
	scanf("%lld",&t);
	while(t--)ss();
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值