Beautiful String

A string is called beautiful if no two consecutive characters are equal. For example, “ababcb”, “a” and “abab” are beautiful strings, while “aaaaaa”, “abaa” and “bb” are not.

Ahcl wants to construct a beautiful string. He has a string ss, consisting of only characters ‘a’, ‘b’, ‘c’ and ‘?’. Ahcl needs to replace each character ‘?’ with one of the three characters ‘a’, ‘b’ or ‘c’, such that the resulting string is beautiful. Please help him!

More formally, after replacing all characters ‘?’, the condition si≠si+1si≠si+1 should be satisfied for all 1≤i≤|s|−11≤i≤|s|−1, where |s||s| is the length of the string ss.

Input

The first line contains positive integer tt (1≤t≤10001≤t≤1000) — the number of test cases. Next tt lines contain the descriptions of test cases.

Each line contains a non-empty string ss consisting of only characters ‘a’, ‘b’, ‘c’ and ‘?’.

It is guaranteed that in each test case a string ss has at least one character ‘?’. The sum of lengths of strings ss in all test cases does not exceed 105105.

Output

For each test case given in the input print the answer in the following format:

If it is impossible to create a beautiful string, print “-1” (without quotes);
Otherwise, print the resulting beautiful string after replacing all ‘?’ characters. If there are multiple answers, you can print any of them.

Sample Input

3
a???cb
a??bbc
a?b?c

Sample Output

ababcb
-1
acbac

Note

In the first test case, all possible correct answers are “ababcb”, “abcacb”, “abcbcb”, “acabcb” and “acbacb”. The two answers “abcbab” and “abaabc” are incorrect, because you can replace only ‘?’ characters and the resulting string must be beautiful.

In the second test case, it is impossible to create a beautiful string, because the 44-th and 55-th characters will be always equal.

In the third test case, the only answer is “acbac”.

题目大意:

如果遇到两个连续非‘?’相等,则输出-1。如果遇到‘?’则做变换,变为不与前后字符相同的字符。

解题思路:

1.遇到‘?’时,直接选择和前一字符不同的字符填入,同时也要注意后一字符是否为问号,避免与后一字符相同。
2.注意数字和字母之间的ASCII码转换,a对应97。

代码如下:
#include<iostream>
#include<algorithm>
#include<cstdio>

using namespace std;

char s[100001];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s",s);
		int flag=0;
		int l=strlen(s);//字符串s的长度
		for(int i=0;i<l;i++)
		{
			if(s[i]==s[i+1]&&s[i]!='?')//与相邻字符相同且非‘?’
			{
				flag=1;//进行标记
				break;
			}
			if(s[i]=='?')
			{
				int count=1;
				while(s[i]=='?'||s[i]==s[i-1]||s[i]==s[i+1])//为‘?’且与前后字符相同
					s[i]=(count++)%3+97;//注意ASCII值的转换
			}
		}
		if(flag)
			printf("-1\n");
		else
			printf("%s\n",s);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值