蓝桥杯 和最大子序列 java

问题描述
  对于一个给定的长度为N的整数序列A,它的“子序列”的定义是:A中非空的一段连续的元素(整数)。你要完成的任务是,在所有可能的子序列中,找到一个子序列,该子序列中所有元素的和是最大的(跟其他所有子序列相比)。程序要求你输出这个最大值。
 
输入格式
  输入文件的第一行包含一个整数N,第二行包含N个整数,表示A。
  其中
  1 <= N <= 100000
  -10000 <= A[i] <=  10000
 
输出格式
  输出仅包含一个整数,表示你算出的答案。
 
 
样例输入
5
3 -2 3 -5 4

 

样例输出

4

 

需要优化输入,不然会超时

import java.io.*;

public class Main {

	public static void main(String[] args) throws IOException{
		Input sc = new Input();
		int n = sc.nextInt();
		int sum = 0;
		int maxn = 0;
		while(n--!=0) {
			int temp = sc.nextInt();
			if(sum + temp >= 0) {
				sum += temp;
			}else {
				sum = 0;
			}
			maxn = Math.max(maxn, sum);
		}
		System.out.println(maxn);
	}

}
class Input {
    StreamTokenizer in = new StreamTokenizer(new BufferedReader(new InputStreamReader(System.in)));
    public int nextInt() throws IOException {
        in.nextToken();
        return (int)in.nval;
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值