A+B for Polynomials

问题描述

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

输入样例

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK where K is the number of nonzero terms in the polynomial, N i and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1 ≤ K ≤ 10,0 ≤ NK < … < N2 < N1 ≤ 1000.

输出格式

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

输入样例

2 1 2.4 0 3.2
2 2 1.5 1 0.5
(结尾无空行)

输出样例

3 2 1.5 1 2.9 0 3.2
(结尾无空行)

C语言代码

#include<stdio.h>
int main(){
	int n, m, count = 0, e;
	float a[1001] = {0}, b[1001] = {0}, k;
	scanf("%d", &n);
	for(int i = 0; i < n; i++){ //循环输入项数和系数
		scanf("%d %f", &e, &k);
		a[e] = k;
	}
	scanf("%d", &m);
	for(int i = 0; i < m; i++){ //循环输入项数和系数
		scanf("%d %f", &e, &k);
		b[e] = k;
	} 
	for(int i = 0; i < 1001; i++){ //对应项数相加
		a[i] = a[i] + b[i];
		if(a[i] != 0) count++; //记录非零项个数
	}
	
	printf("%d",count);
	for(int i = 1000; i >= 0; i--){ //按照题目要求输出
		if(a[i] != 0)
				printf(" %d %.1f",i,a[i]);
	}
	return 0;
}

注意:

  1. 题目中要求项数的个数 [0,1000] ,数组的大小应该设为1001,且每次循环遍历数组时都是1-1000
  2. 按照题目输出结尾无空格,可以采用每个循环输出对前面带上空格,就不用再考虑结尾空格问题

A+B for Polynomials 原题

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值