[PAT A1002]A+B for Polynomials

[PAT A1002]A+B for Polynomials

题目描述

1002 A+B for Polynomials (25 分)This time, you are supposed to find A+B where A and B are two polynomials.

输入格式

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ … N​K​​ a​N​K​​​​
where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

输出格式

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

输入样例

2 1 2.4 0 3.2
2 2 1.5 1 0.5

输出样例

3 2 1.5 1 2.9 0 3.2

解析

简单题,就是输入两个多项式,然后输出他们相加之后的结果

#include<iostream>
using namespace std;
double num1[1010] = { 0 }, num2[1010] = { 0 };
int main()
{
 int n;
 int cnt = 0;
 scanf("%d", &n);
 for (int i = 0; i < n; i++) {
  int a;
  double b;
  scanf("%d %lf", &a, &b);
  num1[a] = b;
 }
 scanf("%d", &n);
 for (int i = 0; i < n; i++) {
  int a;
  double b;
  scanf("%d %lf", &a, &b);
  num2[a] = b;
 }
 for (int i = 0; i < 1010; i++) {
  if (num1[i] != 0 || num2[i] != 0) {
   num1[i] += num2[i];
   if (num1[i] != 0) cnt++;   //注意这里必须要判断是否为零,因为两个互为相反数的项相加为零,这项是没有的
  }
 }
 if (cnt == 0) printf("0");
 else {
  printf("%d ", cnt);
  for (int i = 1009; i >= 0; i--) {
   if (num1[i] != 0) {
    printf("%d %.1f", i, num1[i]);
    cnt--;
    if (cnt != 0)printf(" ");
   }
  }
 }
 return 0;
}
水平有限,如果代码有任何问题或者有不明白的地方,欢迎在留言区评论;也欢迎各位提出宝贵的意见!
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
可以使用面向对象的思想来构建“超市购物”程序。我们可以先定义两个类,一个是商品类,一个是购物者类。商品类中包含属性货物名、货号、价格和数量等信息,还包含获取货物名和价格的方法。购物者类中包含购物清单和购买商品等方法。在购物者类中先定义购物清单列表,再根据购买的商品名称查找商品的价格并计算出总价格。每次购买商品时,还需要统计相应商品的销售数量。 下面是一个示例代码: ```python class Commodity: def __init__(self, name, code, price, quantity): self.name = name self.code = code self.price = price self.quantity = quantity def get_name(self): return self.name def get_price(self): return self.price class Shopper: def __init__(self): self.shopping_list = [] # 初始化购物清单 def add_item(self, commodity, quantity): # 添加购买的商品和对应数量 self.shopping_list.append((commodity, quantity)) def print_receipt(self): # 打印购物清单和总价格 total_price = 0 for commodity, quantity in self.shopping_list: name = commodity.get_name() price = commodity.get_price() sub_total = price * quantity total_price += sub_total print(f"{name} x {quantity} = {sub_total}") print(f"Total price: {total_price}") # 统计销售数量 for commodity, quantity in self.shopping_list: commodity.quantity += quantity # 定义一些商品 commodity1 = Commodity("soap", "A1001", 10, 100) commodity2 = Commodity("pen", "A1002", 5, 200) # 创建购物者并购买商品 shopper = Shopper() shopper.add_item(commodity1, 2) shopper.add_item(commodity2, 3) # 打印购物清单并统计销售数量 shopper.print_receipt() print(commodity1.quantity) print(commodity2.quantity) ``` 运行结果: ``` soap x 2 = 20 pen x 3 = 15 Total price: 35 102 203 ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值