A1075 PAT Judge

问题描述

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

输入格式

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤104 ), the total number of users, K (≤5), the total number of problems, and M (≤105), the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range ***[0, p[problem_id]]***. All the numbers in a line are separated by a space.

输出格式

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] … s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.
The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

输入样例

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0
(结尾无空行)

输出样例

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -
(结尾无空行)

C语言代码

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;

int fullMarks[6] ={0};

struct User{
	char u_id[6];
	int grade[6];
	int full;
	int flag;
	int rank;
}user[10010];

void initialize(int n){ 	//初始化结构体
	for(int i = 0; i < n; i++){
		strcpy(user[i].u_id,"0"); 
		user[i].grade[0] = 0;
		for(int j = 1; j < 6; j++)
			user[i].grade[j] = -2;
		user[i].full = 0;
		user[i].flag = 0;
	}
}

bool cmp(User a, User b){
	if(a.flag != b.flag)
		return a.flag > b.flag;
	else if(a.grade[0] != b.grade[0])
		return a.grade[0] > b.grade[0];
	else if(a.full != b.full)
		return a.full > b.full;
	else
		return strcmp(a.u_id, b.u_id) < 0;  
}

int main(){
	int N, K, M;
	scanf("%d%d%d", &N, &K, &M);
	for(int i = 1; i <= K; i++)
		scanf("%d", &fullMarks[i]);
	initialize(N);
	
//为结构体赋值,按照输入顺序存放用户信息
	int count = 0;
	for(int i = 0; i < M; i++){ 	
		char name[6];
		int order, grade, j; 
		scanf("%s%d%d", name, &order, &grade);
		for(j = 0 ; j < count; j++){
			if(strcmp(name, user[j].u_id) == 0){
				if(grade > user[j].grade[order]){
					user[j].grade[order] = grade;
				}
				break;
			}
		}
		if(j == count){
			strcpy(user[j].u_id , name);
			user[j].grade[order] = grade; 
			count++;
		}
	}
	
//记录总分和满分题目数量
	for(int i = 0 ; i < count; i++){	
		for(int j = 1; j <= K; j++){
			if(user[i].grade[j] == fullMarks[j])
				user[i].full++;
			if(user[i].grade[j] >= 0){
				user[i].grade[0] += user[i].grade[j];
				user[i].flag = 1;
			}
		}
	}
	
	sort(user, user+count, cmp);
	
//记录排名
	user[0].rank = 1;
	for(int i = 1; i < count; i++){
		if(user[i].grade[0] == user[i-1].grade[0])
			user[i].rank = user[i-1].rank;
		else
			user[i].rank = i + 1;
	}
	
//输出结果
	for(int i = 0 ; i < count; i++){
		if(user[i].flag != 0){
			printf("%d %s %d", user[i].rank, user[i].u_id, user[i].grade[0]);
			for(int j = 1; j <= K; j++){
				if(user[i].grade[j] == -2)
					printf(" -");
				else if(user[i].grade[j] == -1)
					printf(" 0");
				else
					printf(" %d", user[i].grade[j]);
			}
			if(i != count-1)
				printf("\n");
		}
	}
	return 0;
}

代码前四个检测点答案正确,第五个检测点运行超时,4个for循环使用当输入样例达到一定数量级,会增加时间成本,对于一些步骤可以合并在一个循环中完成

代码优化

  1. 将全对题目数full及分数-1改写成0存放在成绩grade[ ]中,可以在第一个for循环中完成,排名和输出排名可以在一个for循环中完成
  2. 同时采用顺序存放的方式,用户名是连续的数字,可以采用与user[ ]元素位置对应的方式存放用户信息,减少查找用户是否存在的时间

A1075 PAT Judge原题

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值