【数据结构】NOJ020 基于图的广度优先搜索策略(耿7.11)

1. 题目

在这里插入图片描述

示例输入
4 4
1 2 3 4
1 2
1 3
1 4
2 3
2 3
示例输出
yes

2. 代码

#include <iostream>
#include <queue>

using namespace std;

typedef struct node{
	int data;
	struct node* next;
}EdgeNode;

typedef struct{
	int data;
	EdgeNode *head;
}VexList;

typedef struct{
	int edgenum, vexnum;
	VexList vex[100]; 
}Graph;

Graph *G;
bool visited[100];
queue<int> q;

void CreateGraph(){
	int n, m;
	cin >> n >> m;
	G = (Graph*)malloc(sizeof(Graph));
	G->edgenum = m; G->vexnum = n;
	
	for(int i=1; i<=n; i++){
		cin >> G->vex[i].data;
		G->vex[i].head = NULL;
	}
	int v1, v2;
	for(int i=1; i<=m; i++){
		cin >> v1 >> v2;
		EdgeNode *e = (EdgeNode*)malloc(sizeof(EdgeNode));
		e->data = v2;
		e->next = G->vex[v1].head;
		G->vex[v1].head = e;
	}
}

bool bfs(int v1, int v2){
	while(!q.empty()){
		int tmp = q.front();
		q.pop();
		if(tmp == v2){
			return true;
		}
		EdgeNode *e = G->vex[tmp].head;
		while(e){
			q.push(e->data);
			e = e->next; 
		}
	}
	return false;
}

int main(){
	CreateGraph(); 
	int vs, vt;
	cin >> vs >> vt;
	q.push(vs);
	visited[vs] = true;
	if(bfs(vs, vt))	cout << "yes" << endl;
	else cout << "no" << endl;
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值