L2-006 树的遍历 (25分)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。
输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。
输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

很经典的一道树的题,考了树和队列的知识,首先根据给出的后续和中序还原出二叉树(后续寻找根节点,中序区分左右子树),然后根据队列的知识,依次输出层次遍历的结果。

#include <iostream>
#include <string>
#include<algorithm>
#include<bits/stdc++.h>
#include<stack>
#include<set>
#include <vector>
#include <map>
#include<queue>
using namespace std;
typedef struct Node{
	int data;
	struct Node *left,*right;
}Node,*Tree;
Tree create(int n,int *aft,int *mid){//创建树,递归就完了
	if(n==0){
		return NULL;
	}
    Tree tree=(Tree)malloc(sizeof(Node));
    tree->data=aft[n-1];//找到根节点
    tree->left=tree->right=NULL;
    int i;
    for( i=0;mid[i]!=aft[n-1];i++);
    tree->left=create(i,aft,mid);//找到左子树
    tree->right=create(n-1-i,aft+i,mid+i+1);//找到右子树
    return tree;//返回树
}
void order(int n,Tree tree){
	if(!tree){//如果是空树,直接返回
		return ;
	}
	queue<Tree>qu;//创建队列
	qu.push(tree);//将根节点压入队列
	int len=0;
	while(!qu.empty()){
		Tree t=qu.front();//设定指针
		len++;
		if(len<n){
			cout<<t->data<<" ";
		}
		else{
			cout<<t->data;
		}
		if(t->left){
			qu.push(t->left);
		}
		if(t->right){
			qu.push(t->right);
		}
		qu.pop();
	}
}
int main() {
	ios::sync_with_stdio(false);
	int n;
	cin>>n;
	int aft[n],mid[n];
	for(int i=0;i<n;i++){
		cin>>aft[i];//后续
	}
	for(int i=0;i<n;i++){
		cin>>mid[i];//中序
	}
	Tree tree=create(n,aft,mid);
	order(n,tree);
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_努力努力再努力_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值