设某银行有A、B两个业务窗口,且处理业务的速度不一样,其中A窗口处理速度是B窗口的2倍 —— 即当A窗口每处理完2个顾客时,B窗口处理完1个顾客。给定到达银行的顾客序列,请按业务完成的顺序输出顾客序列。假定不考虑顾客先后到达的时间间隔,并且当不同窗口同时处理完2个顾客时,A窗口顾客优先输出。
输入格式:
输入为一行正整数,其中第1个数字N(≤1000)为顾客总数,后面跟着N位顾客的编号。编号为奇数的顾客需要到A窗口办理业务,为偶数的顾客则去B窗口。数字间以空格分隔。
输出格式:
按业务处理完成的顺序输出顾客的编号。数字间以空格分隔,但最后一个编号后不能有多余的空格。
输入样例:
8 2 1 3 9 4 11 13 15
输出样例:
1 3 2 9 11 4 13 15
定义三个队列,一个是A窗口一个是B窗口,还有一个队列便于输出,首先将基数放a,偶数放b,然后循环,详细解析见代码;
#include <iostream>
#include <string>
#include<algorithm>
#include<bits/stdc++.h>
#include<stack>
#include<set>
#include <vector>
#include <map>
#include<queue>
#include<deque>
using namespace std;
int main() {
queue<int>a;
queue<int>b;
queue<int>q;
int n;
cin>>n;
while(n--){
int x;
cin>>x;
if(x%2==0){
b.push(x);
}
else{
a.push(x);
}
}
while(a.size()&&b.size()){//如果a和b有一个是空了都退出循环
q.push(a.front());
a.pop();
if(!a.empty()){//这里需要单独判断一下,如果此时a空,也退出循环
q.push(a.front());
a.pop();
q.push(b.front());
b.pop();
}
else break;
}
while(a.size()){//若a没空,将剩下的放入队列q中
q.push(a.front());
a.pop();
}
while(b.size()){//同上
q.push(b.front());
b.pop();
}
int len=q.size();
for(int i=0;i<len;i++){//这不主要是为了格式,不能有多余空格,注意先用len将size接住,否者size是会变的。
if(!i){
cout<<q.front();
q.pop();
}
else{
cout<<" "<<q.front();
q.pop();
}
}
return 0;
}