1092 To Buy or Not to Buy (20 分)

360 篇文章 3 订阅
91 篇文章 1 订阅

Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.

For the sake of simplicity, let’s use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

figbuy.jpg

Figure 1

Input Specification:
Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:
For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:

ppRYYGrrYBR2258
YrR8RrY

结尾无空行

Sample Output 1:
Yes 8

结尾无空行
Sample Input 2:

ppRYYGrrYB225
YrR8RrY

结尾无空行
Sample Output 2:

No 2

理解错题目的意思了,我以为是,如果输出 yes,算出有多少需要多余买的,而不是剩余的,挺痛苦,其实挺简单的,只需要两个字符串即可,遍历第二个字符串,如果能在第一个找到,说明找到一个需要的,那么删除第一个字符串的元素,如果找不到,说明有缺失的珠子,定义一个变量记录

如果有缺失的珠子,说明没找到,输出 No
如果都找到了,只需要让 两个字符串的长度做差。

#include<iostream>
#include<string>
#include<algorithm>
#include<bits/stdc++.h>
#include<stack>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<deque>
#include<cctype>
#include<unordered_set>
#include<unordered_map>
#include<fstream>
#include<cstring>
using namespace std;
int main() {
	string s;
	string ss;
	cin >> s >> ss;
	int t1 = s.size(), t2 = ss.size();
	int misCount = 0;
	for (int i = 0; i < ss.length(); i++) {
		int index = s.find(ss[i]);
		if (index != -1) {
			s.erase(s.begin() + index);
			
		} else {
			misCount++;
		}
	}
	if (misCount) {
		cout << "No " << misCount;
	} else {
		cout << "Yes " << t1 - t2;
	}
	
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_努力努力再努力_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值