1092 To Buy or Not to Buy (20 分) java 题解

Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.

For the sake of simplicity, let's use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

figbuy.jpg

Figure 1

Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:

For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:

ppRYYGrrYBR2258
YrR8RrY

Sample Output 1:

Yes 8

Sample Input 2:

ppRYYGrrYB225
YrR8RrY

Sample Output 2:

No 2

题目大意:

给定两字符串,判断是否第一串包含了第二串的全部字符(字符个数也在内),如果是,给出包含的多余的数量,否则输出不够的数量。

解题思路:

典型的map散列问题。可以先将第二串字符映射到map,再遍历第一串,遍历时,当某一字符是map中元素,则将其value值减1,否则不作处理。最后遍历map,若出现value为正值,则将其累加到一全局变量ans上,否则不做处理。输出时,则判断ans是否为0,若果不是,说明商店给定的珠子不够,直接输出ans值,否则即为够,输出两字符串差即可。

java代码:

import java.io.*;
import java.util.*;

public class Main {
	public static void main(String[] args) throws IOException {
		BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
		String s1 = br.readLine();
		String s2 = br.readLine();
		Map<Character,Integer> map = new HashMap<>();
		for(int i = 0; i < s2.length(); i++) {
			char c = s2.charAt(i);
			Integer value = map.get(c);
			if(value == null) {
				map.put(c, 1);
			}else {
				map.put(c, value + 1);
			}
		}
		for(int i = 0; i < s1.length(); i++) {
			char c = s1.charAt(i);
			Integer value = map.get(c);
			if(value != null) {
				map.put(c, value - 1);
			}
		}
		Iterator<Character> iterator = map.keySet().iterator();
		int ans = 0;
		while(iterator.hasNext()) {
			Character key = iterator.next();
			Integer value = map.get(key);
			if(value > 0) {
				ans += value;
			}
		}
		if(ans == 0) {
			System.out.print("Yes " + (s1.length() - s2.length()));
		}else {
			System.out.print("No " + ans);
		}
	}
}

PTA提交截图:

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值