1046 Shortest Distance (20 分)

360 篇文章 3 订阅
91 篇文章 1 订阅

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,10 5 ]), followed by N integer distances D 1​ D ​ ⋯ D N​ , where D i​ is the distance between the i-th and the (i+1)-st exits, and D N is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10
4 ), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10 7Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1
结尾无空行

Sample Output:

3
10
7
结尾无空行

本题,典型的前缀和问题,当给出起点和终点让求路径的问题,别想,绝对是前缀和。

定义一个数组 a 存放路径,b 存放前缀和,total 是总路径(因为是个环,如果正向的路径与总路径 - 正向的路径相比,要大,说明要逆着走),然后就没啥了,前缀和是 b[i] = a[i] + b[i - 1]

然后就是注意最后是 b[y - 1] 数组,因为题目是 i -> i + 1 的距离是 a[i] 这个可以通过结果再调试

#include<iostream>
#include<string>
#include<algorithm>
#include<bits/stdc++.h>
#include<stack>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<deque>
#include<cctype>
#include<unordered_set>
#include<unordered_map>
#include<fstream>
#include<cstring>
using namespace std;
int main(){
	int n;
	cin >> n;
	int a[n + 1], b[n + 1];
	int total = 0;
	for (int i = 1; i <= n; i++) {
		cin >> a[i];
		total += a[i];
		b[i] = b[i - 1] + a[i];
	}
	int m;
	cin >> m;
	while (m--) {
		int x, y;
		cin >> x >> y;
		if (y < x) {
			swap(y, x);
		}
		int sum = b[y - 1] - b[x - 1];
		cout << min(total - sum, sum) << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_努力努力再努力_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值