1013 Battle Over Cities (25 分)(段错误分析)

360 篇文章 3 订阅
91 篇文章 1 订阅

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city 1 -city 2​ and city 1​ -city 3​ . Then if city 1​ is occupied by the enemy, we must have 1 highway repaired, thatisthe highway city 2​ -city 3.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

结尾无空行
Sample Output:

1
0
0

结尾无空行

标准并查集代码:

由于本题一分析,是一个求图连通性的题目,所以我们采用并查集,使用结构体存储路径,并查集的结果就不分析了,使用 vector 存储失去的城市,然后遍历 vector,每次重置并查集,遇到市区的城市直接跳过,求连通量,由于有一个肯定被控破,而且两个城市只需要一条路就能够联通,所以只需要让 count - 2 就是结果。

段错误分析:相信很多人看到 N 小于等于 1000,直接让结构体最大为 1000 ,这样会引发段错误,因为结构体的大小是高速公路的大小,N 个城市直接可以有不止 N 条高速,所以结构体的个数要足够大,我这里直接多加了几个零,就AC 了。

#include<iostream>
#include<string>
#include<algorithm>
#include<bits/stdc++.h>
#include<stack>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<deque>
#include<cctype>
#include<unordered_set>
#include<unordered_map>
#include<fstream>
#include<cstring>
using namespace std;
const int N = 1001;
int n;
struct Node {
	int u;
	int v;
}tt[1000001];
int father[N];
int findFather(int x) {
	if (x == father[x]) {
		return x;
	} else {
		int F = findFather(father[x]);
		father[x] = F;
		return F; 
	}
}
void Union(int x, int y) {
	int fa = findFather(x);
	int fb = findFather(y);
	if (fa != fb) {
		father[fa] = fb;
	}
}
void Init() {
	for (int i = 1; i < N; i++) {
		father[i] = i;
	}
}
int main() {
	int m, k;
	cin >> n >> m >> k;
	Init();
	for (int i = 0; i < m; i++) {
		int a, b;
		cin >> a >> b;
		Union(a, b);
		tt[i].u = a;
		tt[i].v = b;
	}
	vector<int> v;
	for (int i = 0; i < k; i++) {
		int x;
		cin >> x;
		v.push_back(x);
	}
	for (int i = 0; i < k; i++) {
		int count = 0;
		Init();
		for (int j = 0; j < m; j++) {
			if (tt[j].u == v[i] || tt[j].v == v[i]) {
				continue;
			} else {
				Union(tt[j].u, tt[j].v);
			}
		}
		for (int j = 1; j <= n; j++) {
			if (father[j] == j) {
				count++;
			}
		}
		cout << count - 2 << endl;
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_努力努力再努力_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值