1044 Shopping in Mars (25 分)(滑动窗口详解,测试点二分析)

360 篇文章 3 订阅
91 篇文章 1 订阅

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).
Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10
5
), the total number of diamonds on the chain, and M (≤10
8
), the amount that the customer has to pay. Then the next line contains N positive numbers D
for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print i-j in a line for each pair of i ≤ j such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + … + Dj >M with (Di + … + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

结尾无空行
Sample Output 1:

1-5
4-6
7-8
11-11

结尾无空行
Sample Input 2:

5 13
2 4 5 7 9

结尾无空行
Sample Output 2:

2-4
4-5

结尾无空行

本题,我是用滑动窗口进行解答的,一开始 只拿了 18 分,去搜了搜解析,但是大家都用的二分法,寥寥几个滑动窗口还都是互相模仿的,不得不说 CSDN 的抄袭人是真的多,无奈,只能再读读题,哪里有细节错误,结果还真是审题的问题。

首先说一下测试点二的考察,就是当不能像等的时候,这段话是指输出差值最小的那几个区间
If there is no solution, output i-j for pairs of i ≤ j such that Di + … + Dj >M with (Di + … + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.
结果我给想成,如果不想等,只要是大的都输出,这不是纯纯zz 吗,审题很重要阿,本题,我是一点点摸索解答的,所以代码比较繁琐,不过思路是非常清晰的,分析如下:

维护两个指针,两个指针之间的区间为一个窗口,如果此时窗口的值小于 m,说明需要扩大窗口,此时让右边界加加,同时 更新 sum

如果此时窗口的值大于等于 sum 了,那么情况就比较特殊了,因为不能保证窗口前面的元素是否还能去掉,比如当 m 等于 15 的时候,如果 窗口为 2 5 7 3 是大于等于 m 的,但是去掉 2 还是大于等于 m,所以要把左窗口缩短

定义 min_cha 为最小差值,如果遇到更小的,需要先清空 v 然后再添加,如果遇到等于的,直接添加

本题很有意思,建议作对

#include<iostream>
#include<string>
#include<algorithm>
#include<bits/stdc++.h>
#include<stack>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<deque>
#include<cctype>
#include<unordered_set>
#include<unordered_map>
#include<fstream>
#include<cstring>
using namespace std;
int a[100001];
int main() {
	int n, m;
	cin >> n >> m;
	for (int i = 1; i <= n; i++) {
		cin >> a[i];
	}
	vector<int> v;
	int min_cha = 999;
	int i = 1, j = 1, sum = a[1];
	bool flag = false;
	while (i <= j + 1 && j <= n && i <= n) {
		if (sum < m) {
			j++;
			sum += a[j];
		} else {
			while (sum - a[i] >= m) {
				sum -= a[i];
				i++;
			}
			if (sum >= m) {
				int cha = sum - m;
				if (cha < min_cha) {
					min_cha = cha;
					v.clear();
					v.push_back(i);
					v.push_back(j);
				} else if (cha == min_cha) {
					v.push_back(i);
					v.push_back(j);
				}
			}
			sum -= a[i];
			i++;
		}
	}
	for (int i = 1; i < v.size(); i += 2) {
		cout << v[i - 1] << "-" << v[i] << endl;
	}

	return 0;
}




  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_努力努力再努力_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值