1040 Longest Symmetric String (25 分)(暴力双循环)

360 篇文章 3 订阅
91 篇文章 1 订阅

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:
Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:
For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

结尾无空行
Sample Output:

11

结尾无空行

暴力法解答,直接双循环,每次截取指定区间字符串,判断是否是对称,如果是对称,记录最大对称长度即可。

#include<iostream>
#include<string>
#include<algorithm>
#include<bits/stdc++.h>
#include<stack>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<deque>
#include<cctype>
#include<unordered_set>
#include<unordered_map>
#include<fstream>
#include<cstring>
using namespace std;
int main() {
	string s;
	getline(cin, s);
	int max_len = -1;
	for (int i = 0; i < s.length(); i++) {
		for (int j = 1; j <= s.size() - i; j++) {
			string ss = s.substr(i, j);
			string sss = ss;
			reverse(ss.begin(), ss.end());
			if (sss == ss) {
				int len = sss.length();
				max_len = max(max_len, len);
			} 
		}
	}
	cout << max_len;
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_努力努力再努力_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值