1149 Dangerous Goods Packaging (25 分)(结构体)

360 篇文章 3 订阅
91 篇文章 1 订阅

When shipping goods with containers, we have to be careful not to pack some incompatible goods into the same container, or we might get ourselves in serious trouble. For example, oxidizing agent (氧化剂) must not be packed with flammable liquid (易燃液体), or it can cause explosion.

Now you are given a long list of incompatible goods, and several lists of goods to be shipped. You are supposed to tell if all the goods in a list can be packed into the same container.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: N (≤10
4
), the number of pairs of incompatible goods, and M (≤100), the number of lists of goods to be shipped.

Then two blocks follow. The first block contains N pairs of incompatible goods, each pair occupies a line; and the second one contains M lists of goods to be shipped, each list occupies a line in the following format:

K G[1] G[2] … G[K]
where K (≤1,000) is the number of goods and G[i]'s are the IDs of the goods. To make it simple, each good is represented by a 5-digit ID number. All the numbers in a line are separated by spaces.

Output Specification:
For each shipping list, print in a line Yes if there are no incompatible goods in the list, or No if not.

Sample Input:
6 3
20001 20002
20003 20004
20005 20006
20003 20001
20005 20004
20004 20006
4 00001 20004 00002 20003
5 98823 20002 20003 20006 10010
3 12345 67890 23333
结尾无空行
Sample Output:
No
Yes
Yes
结尾无空行

本题,想了很多种办法存储,以前是用的 二维数组存储,但是这次我使用的是结构体加数组的方式,没有以前好写,但是我思考的时候思路过去了,就顺着写了。

#include<iostream>
#include<string>
#include<algorithm>
#include<bits/stdc++.h>
#include<stack>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<deque>
#include<cctype>
#include<unordered_set>
#include<unordered_map>
#include<fstream>
#include<cstring>
using namespace std;
struct Node {
	vector<int> v; 
}a[100000];
int main() {
	int n, m;
	cin >> n >> m;
	vector<vector<int>>v;
	for (int i = 1; i <= n; i++) {
		int id1, id2;
		cin >> id1 >> id2;
		a[id1].v.push_back(id2);
		a[id2].v.push_back(id1);
	}
	while (m--) {
		int k;
		cin >> k;
		set<int> st;
		bool flag = true;
		for (int i = 0; i < k; i++) {
			int id;
			cin >> id;
			st.insert(id);
		}
		for (auto it = st.begin(); it != st.end(); it++) {
			for (int i = 0; i < a[*it].v.size(); i++) {
				if (st.find(a[*it].v[i]) != st.end()) {
					flag = false;
					break;
				}
			}
			if (flag == false) {
				break;
			}
		}
		if (flag) {
			cout << "Yes" << endl;
		} else {
			cout << "No" << endl;
		}

	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_努力努力再努力_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值