1115 Counting Nodes in a BST (30 分)

360 篇文章 3 订阅
91 篇文章 1 订阅

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than or equal to the node’s key.
The right subtree of a node contains only nodes with keys greater than the node’s key.
Both the left and right subtrees must also be binary search trees.
Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−1000,1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:
For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n
where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

结尾无空行
Sample Output:

2 + 4 = 6

结尾无空行

题目大意:创建二叉搜索树,然后输出最底层和次底层的节点个数,分析如下:

首先,建立二叉搜索树,然后通过广度优先,将每层的节点数存储到 v 里面,最后输出即可

#include<iostream>
#include<bits/stdc++.h>
#include<string>
#include<set>
#include<map>
#include<vector>
#include<queue>
#include<deque>
#include<unordered_set>
#include<unordered_map>
#include<cctype>
#include<algorithm>
#include<stack>
using namespace std;
typedef struct Node {
	int val;
	struct Node *left, *right;
}Node, *Tree;
vector<int> v[1001];// 存储某层的所有节点
int level = 1;
Tree create(Tree root, int x) {
	if (root == NULL) {
		root = new Node();// 这一步不能少哈,如果少了,空是没有左和右的
		root->val = x;
		root->left = root->right = NULL;
	} else {
		if (x <= root->val) {
			root->left = create(root->left, x);
		} else {
			root->right = create(root->right, x);
		}
	}
	return root;
}
void Bfs(Tree root) {
	if (!root) {
		return;
	}
	queue<Tree> qu;
	qu.push(root);
	while (!qu.empty()) {
		int size = qu.size();
		for (int i = 0; i < size; i++) {
			Tree t = qu.front();
			v[level].push_back(t->val);
			qu.pop();
			if (t->left) {
				qu.push(t->left);
			}
			if (t->right) {
				qu.push(t->right);
			}
		}
		level++;	
	}
}
int main() {
	int n;
	cin >> n;
	Tree root = NULL;
	for (int i = 0; i < n; i++) {
		int x;
		cin >> x;
		root = create(root, x);
	}	
	Bfs(root);
	int low = level - 1;
	int above = level - 2;
	cout << v[low].size() << " + " << v[above].size() << " = " << v[above].size() + v[low].size();
	
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_努力努力再努力_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值