1074 Reversing Linked List (25 分)(详解)

360 篇文章 3 订阅
91 篇文章 1 订阅

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10
5
) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

结尾无空行
Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

结尾无空行

本题在 LeetCode 上都是难题,我也不知道为啥只有 25 分,解析:
LeetCode k 各一组反转链表

注意输出格式。

#include<iostream>
#include<bits/stdc++.h>
#include<string>
#include<set>
#include<map>
#include<vector>
#include<queue>
#include<deque>
#include<unordered_set>
#include<unordered_map>
#include<cctype>
#include<algorithm>
#include<stack>
using namespace std;
struct Node {
	int val;
	int next;
}a[100001];
int reverse(int node) {
	int pre = -1;
	while (node != -1) {
		int next = a[node].next;
		a[node].next = pre;
		pre = node;
		node = next;
	}
	return pre;
}
int main() {
	int head, n, k;
	cin >> head >> n >> k;
	for (int i = 0; i < n; i++) {
		int node, x, next;
		cin >> node >> x >> next;
		a[node].val = x;
		a[node].next = next;
	}
	int hair = 100000;
	a[hair].next = head;
	int start = hair;
	int end = hair;
	while (a[end].next != -1) {
		for (int i = 0; i < k && end != -1; i++) {
			end = a[end].next;
		}
		if (end == -1) {
			break;
		}
		int left = a[start].next;
		int right = a[end].next;
		a[end].next = -1;
		a[start].next = reverse(left);
		a[left].next = right;
		start = left;
		end = left;
	}
	printf("%05d %d ", a[hair].next, a[a[hair].next].val);
	while (a[a[hair].next].next != -1) {
		
		printf("%05d\n", a[a[hair].next].next);
		hair = a[hair].next;
		printf("%05d %d ", a[hair].next, a[a[hair].next].val);
	}
	printf("-1");
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_努力努力再努力_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值