1068 Find More Coins (30 分)(背包问题)

360 篇文章 3 订阅
91 篇文章 1 订阅

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 10
4
coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10
4
, the total number of coins) and M (≤10
2
, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

=M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output “No Solution” instead.

Note: sequence {A[1], A[2], …} is said to be “smaller” than sequence {B[1], B[2], …} if there exists k≥1 such that A[i]=B[i] for all i<k, and A[k] < B[k].

Sample Input 1:

8 9
5 9 8 7 2 3 4 1

结尾无空行
Sample Output 1:

1 3 5

结尾无空行
Sample Input 2:

4 8
7 2 4 3

Sample Output 2:

No Solution

本题,如果要求序列是连续的,就使用滑动窗口,如果要求是字典序,就得使用零一背包了,本题思路:

首先,根据给定的序列求和,如果总和都小于 m,说明直接 no solution
然后排序,从第一个开始深搜
如果结果大于 sum,或者已经有了结果,返回
如果结果等于sum,并且没结果,更新结果,返回
每次深搜,然后再回溯即可

#include<iostream>
#include<bits/stdc++.h>
#include<string>
#include<set>
#include<map>
#include<vector>
#include<queue>
#include<deque>
#include<unordered_set>
#include<unordered_map>
#include<cctype>
#include<algorithm>
#include<stack>
using namespace std;
int n, m;
vector<int> ans;
vector<int> res;
vector<int> v;
bool flag = false;
void Dfs(int index, int sum) {
	if (sum > m || flag) {
		return;
	}
	if (sum == m && !flag) {
		res = ans;
		flag = true;
		return;
	}
	for (int i = index; i < n; i++) {
		ans.push_back(v[i]);
		Dfs(i + 1, sum + v[i]);
		ans.pop_back();
	}
}
int main() {
	scanf("%d%d", &n, &m);
	int sum = 0;
	for (int i = 0; i < n; i++) {
		int x;
		scanf("%d", &x);
		sum += x;
		v.push_back(x);
	}
	if (sum < m) {
		cout << "No Solution";
		return 0;
	}
	sort(v.begin(), v.end());
	Dfs(0, 0);
	if (flag) {
		for (int i = 0; i < res.size(); i++) {
			if (!i) {
				printf("%d", res[i]);
			} else {
				printf(" %d", res[i]);
			}
		}
	} else {
		printf("No Solution");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_努力努力再努力_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值