1064 Complete Binary Search Tree (30 分)

360 篇文章 3 订阅
91 篇文章 1 订阅

1064 Complete Binary Search Tree (30 分)
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

结尾无空行
Sample Output:

6 3 8 1 5 7 9 0 2 4

结尾无空行

一直在想这个完全二叉搜索树,完全有啥用,原来是根节点 x,左孩子就是 x * 2,右孩子是 x * 2 + 1,所以这样就能够进行中序遍历,也就能够还原出一个树了,由于完全二叉树的层次遍历就是按数组顺序输出的,所以直接输出即可。

#include<iostream>
#include<bits/stdc++.h>
#include<string>
#include<set>
#include<map>
#include<vector>
#include<queue>
#include<deque>
#include<unordered_set>
#include<unordered_map>
#include<cctype>
#include<algorithm>
#include<stack>
using namespace std;
const int N = 1001;
int mid[N];
int order[N];
int n;
int index1 = 1;
void inorder(int root) {
	if (root > n) {
		return;
	}
	inorder(root * 2);
	order[root] = mid[index1++];// 当前这个点的前序位置
	inorder(root * 2 + 1); 
}
int main() {
	cin >> n;
	for (int i = 1; i <= n; i++) {
		cin >> mid[i];
	}
	sort(mid + 1, mid + n + 1);
	inorder(1);
	for (int i = 1; i <= n; i++) {
		if (i == 1) {
			cout << order[i];
		} else {
			cout << " " << order[i];
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_努力努力再努力_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值